1

Long story short: I'm on OSX 10.6.8 and I'm trying to download the Yosemite package in order to (re)create a bootable USB.

When I go to the App Store, I go to the first tab and click on "Free" under yosemite and the OSX icon appears on the bottom bar:

enter image description here

If I hover over it it says "Downloading...". I wanted to check out the speed and progress of the download, but apparently if I go to App Store > Purchased tab, what I see is this:

enter image description here

while, as I understand, there should be informations about the current download.

I've already done this process once already from 10.6.8 on the same computer and I succeeded. This is a clean install of Snow Leopard (updated to 10.6.8) though and my download speed is very low (0.99Mb/s vs 5Mb/s I had back then) this week.

I've tried canceling the download, trying again. I've tried restarting (also shutting down and then manually start it again), as well as canceling and restarting the download numerous times. I've also tried starting the download from the Purchased tab, but that doesn't seem to start the download and just makes the "Download" button go back grey again. Even waiting for a while doesn't show any message and/or progress.

What should I do next?

  • To delete the download, open Launchpad and press the app that it's downloading to pause the download instead of deleting the app – Ruskes Nov 1 '14 at 23:05
2

I've solved this by making sure there were no updates left. Basically after the first "cycle of updates" after a clean install, new updates are silently "unlocked". You need to run all updates. One of them fixes the problem.

1

I found that I had to delete all instances of "Install OSX Yosemite", which I had renamed to "Install OSX Yosemite_10.10.1" from /Applications/ and eject my old USB key, which was labeeled "Install OSX Yosemite_10.10.1" before my computer would download the latest (10.10.2) installer.

Just FWIW, might be worth a try

0

Try to close the "app store" application and open it again, go to updates and it shows the process status...

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .