3

When I am in the home screen, in landscape mode, and swipe down to bring up spotlight search the keyboard shows up as if I was in portrait mode. See the screenshot below:

iPad screenshot

It's not a problem with the orientation lock, because the screen does rotate. The keyboard always shows up on at the bottom of the iPad, regardless of what orientation I hold the iPad. If I hold the iPad upside down, the keyboard will drop down from the top. (Not only making it very hard to use, but completely obscuring the search dialog box.)

This does not happen in any apps. In apps the keyboard always appears where it should.

Any ideas on how to fix this? I am currently on iOS 8.1, but this was happening on iOS 8.0 as well. I'm not sure if it had that problem before then.

2

Looks like one of the many keyboard issues in iOS 8.

Might need to wait for Apple to fix it.

See https://discussions.apple.com/thread/6581211 & many others

  • I kind of figured as much, but I was hoping someone had a workaround. That thread didn't have much useful information in it, the only advice was to reboot (which I've tried). – David Ogren Nov 1 '14 at 22:09
  • This did resolve itself with 8.1.1 so I will mark as the correct answer. – David Ogren Nov 18 '14 at 14:34
  • FWIW, it's broken again. – David Ogren Nov 30 '14 at 13:25
  • :0( I don't think there's anything the user can do about it, there have been many issues with the keyboard since Apple opened it to 3rd parties – Tetsujin Nov 30 '14 at 13:34
0

Updating to iOS 8.1.2 addressed this issue for me

0

Apple is probably clueless about this. My ipad air at 8.1.2 & the issue still exists. I have not seen any pattern for this (as in which app I opened or worked on before). I even tried killing all the apps & that did not clear this error.

The only way to get rid of this is to reset or Power cycle the ipad.

0

I did the following and the problem went away - non rotating keyboard problem went away

  • Reset keyboard
  • Reset Home screen layout
  • Deselected split keyboard option
  • Power cycled

Problem went away (but only after doing all steps above).

Note - I had power cycled many times before this and the problem did not go away. I wish I had done each separately but the problem has been resolved for the first time since updating to iOS 8 so I am happy.

0

If this happens to you in iOS 10, there's a solution that's worked for me in the past (note: if you're not on iOS 10, upgrade to get there):

  1. Navigate to SettingsGeneralResetReset Home Screen Layout (this will reset the layout of your home screen icons but you will not lose any other data).
  2. Power cycle the iPad.

This should fix the issue and allow the iPad's keyboard to rotate correctly once again. As per @flowscape's solution here.

  • I have posted this for the user @flowscape, who posted this answer as a question instead of an answer (because he has insufficient rep to answer this locked question). – owlswipe Feb 19 '17 at 3:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .