10

Here is the screen shot and it's not working anymore after upgrading to Yosemite enter image description here

NOTE: Although if I add this shortcuts under all applications then it works. I don't know why it's not working, wasted my time and I found on apple discussion forum that in Languages there should be only one language and that doesn't work for me.

5
  • 1
    It's your custom shortcut for Preview that's not working, yes? I'm having the exact same problem (though with a different menu item). I have other shortcuts for other apps that work fine, but Preview does not.
    – NReilingh
    Nov 3, 2014 at 3:21
  • 1
    But thanks for the hint about the "All Applications" workaround -- I hadn't tried that.
    – NReilingh
    Nov 3, 2014 at 3:22
  • Report the bug to Apple bugreport.apple.com/logon . This goes directly to apple engineering.
    – smileBot
    Dec 18, 2014 at 19:26
  • 2
    @cocoanut Reported :) Dec 19, 2014 at 5:49
  • @InderKumarRathore I also filed a report. Mean while I'm using Keyboard Maestro, which is such a cool app anyway.
    – smileBot
    Dec 19, 2014 at 17:18

4 Answers 4

2

I have reported this bug to apple and it's still not being closed. I will update my answer once it's closed.

Till then you can add this shortcuts under all applications(instead of preview) then it will work.

1
  • Such an annoying bug. I had to add my "Rename..." shortcut to All Applications instead of Preview.app
    – wisbucky
    Jan 11, 2017 at 11:13
1

I don't know why this isn't working either, but I ran into it with Mavericks too.

I've tried both "…" (proper ellipses) and "..." (three .) and neither of them work.

So I made a Keyboard Maestro macro for it instead:

Screenshot of Keyboard Maestro macro, described below

The key here is that the "Group" (labeled "1") is set up to only be active in Preview.app.

Then the macro (labeled 2) is where we explain what we want to have happen.

The "Trigger" (3) in this case is the same keyboard shortcut (aka "hot key") ⌘ ⇧ Z but could be anything

Then the action is to trigger the menu item Tools ---> Adjust Size...

(The "Stop macro is menu cannot be selected" might seem superfluous since there are no more actions after this one, however, if that happens, Keyboard Maestro will show an error to the user, which can be helpful. Otherwise it just silently fails.)

You can download my Keyboard Maestro macro here. Unzip it, double click on it to import it into Keyboard Maestro, and it will create the "Preview only" group and add the macro to it.

I still don't know why the official Keyboard Shortcut doesn't work in Preview.app, but an added bonus of using Keyboard Maestro is that since it can sync (using iCloud Drive or Dropbox), you can have it on all of your Macs. Keyboard Shortcuts added to the OS X System Preferences don't sync. Yet another reason I like Keyboard Maestro.

4
  • 1
    Thanks for your suggestion but personally I don't like third party sw for the task that can be done using in built applications. Nov 5, 2014 at 5:18
  • I can understand that. (Of course, in this case, it can't be done using the built-in application, but I get your meaning.) Having my keyboard shortcuts sync is definitely worth the reliance on a 3rd party app that I'd definitely insist on installing on any Mac I plan to use for any meaningful length of time!
    – TJ Luoma
    Nov 6, 2014 at 19:42
  • Thanks Luoma.. I will surely try if I can't find the solution :) Nov 7, 2014 at 4:56
  • This is a good suggestion. Keyboard Maestro is brilliant. I'm having the same issue in many applications.
    – smileBot
    Dec 18, 2014 at 19:23
0

I had a shortcut in Mavericks (option+T) to bring up the Tags box in Finder. Yosemite killed it, whether All Applications or Finder. Apple Support could not solve it, however I discovered that it will work if set to control+T instead.

1
  • Option shortcuts are normally used for special characters on a Mac. May 4, 2015 at 15:32
0

If using keyboard with number pad use the numbers on the top not the number pad. Don't know why it is different but it works for me using the numbers on top.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .