I am using Yosemite on MBP 15 mid2010

I already tried this tutorial http://vadimk.com/2010/10/11/xerox-phaser-3117-mac/

Didn't work for me.

Also tried Splix: http://www.guigo.us/mac/splix/

again, didn't work.

Any idea how to get the printer running?



This problem is probably due to kext signing introduced with OS X 10.10 Yosemite. With it you can't run any unsigned drivers and Splix is being a port of Samsung GDI open sourced driver is just a driver and last version being from 2008 it is definitely unsigned.

Basically you have no choice but disable kext signing if you want to use the printer. Make sure you absolutely have to do it and you don't have other options since this change is system wide and system is becoming less secure after that.

In Terminal:

sudo nvram boot-args="kext-dev-mode=1"

And reboot. Then try to go with Splix.

| improve this answer | |
  • Another danger of unsigned kexts on Yosemite is if for some reason the NVRAM is reset. This page says “If you try to boot a [Yosemite Mac with unsigned kext] with the kext-signing setting re-activated, you will be met by a gray screen with a stop sign”: cindori.org/trim-enabler-and-yosemite – Pascal Cuoq Dec 24 '14 at 21:37
  • 1
    @PascalCuoq it is indeed a danger but I doubt it will apply under this particular circumstances. You see when you enable TRIM on 3rd party drive you patch system IOAHCIBlockStorage.kext signed by Apple. It is crucial to system boot and can't be omitted. When using Splix you just install additional driver which will be just not loaded if signing rule be reapplied. – iskra Dec 24 '14 at 22:27

I am on Yosemite and wasted my whole day with this and finally came up with a simple but interesting solution.

Since there is no other option, I used an application like WMware Fusion (or Parallel Desktop). You can install any version of windows. For instance, I installed the good old Windows XP. As long as your printer's legit driver is available for that version of windows everything is fine. Just install your Xerox printer in the Printers option (Control Panel) and that's it!!! Just print everything in there.

It works much faster than when I used with an emulation file of some other weird generic printer. No fonts problem either, all are original.

Until Xerox solves this, this will be my solution for now.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .