3

First off I know there's a Weather widget in Today view which is working fine for me. What I am referring to is the weather information that shows up right on top under the big date section for some users as below:

enter image description here

Whereas my Today View looks like this:

enter image description here

What gives?

Edit: For what it's worth, here's what my Location Services pane looks like:

enter image description here

2

I had the same problem and this fixed it:

  1. Open Notification Center
  2. Click the grey Edit button at the very bottom
  3. Click the red minus icon (-) next to Today to remove it
  4. Click the green plus icon (+) next to Today Summary to add it back

Once I added it back, the weather summary popped up.

1
  1. Try to switch off and on again the weather-location mode.
  2. Disable and enable again "Today" item in your notifications.
  3. Restart your system.

It helps to me.

  • 1
    Thanks for your advice and sorry for being a tad lost here but how exactly do you disable/enable "Today" item in Notification Center? – TheLearner Nov 9 '14 at 17:39
  • Just try that @daGUY offered below. Even noticed that I had the same problem today. It repeated permanently. I think that it's system problem, maybe Apple will fix it in previous uptake. Also I have this trouble in notifications with weather app. – k1r8r0wn Nov 10 '14 at 3:58
  • 1
    Just tried it with no success. But thanks for your efforts anyway. – TheLearner Nov 10 '14 at 7:08
1

Check that you have allowed weather to access your current location.

In System Preference -> Security & Privacy -> Privacy tab -> Location Services

system preference screenshot

  • Thanks for your response but that doesn't help unfortunately. My Location Services does show a check mark against Weather but it doesn't have that black icon next to it. Not sure how to force it to request location. Please see the screenshot updated in the question. – TheLearner Nov 1 '14 at 13:39
  • Mine doesn't show weather at all in location services, and it shows no locations in the notification centre. Maps works fine. – Synchro Feb 9 '15 at 23:16
0

Is your Wi-Fi turned off? I had the same problem, and realized that it was because my Mac couldn't find my location since Wi-Fi was turned off (I was connected via Ethernet and this Mac does not have a GPS chip).

When I switched Wi-Fi on, it immediately started working

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .