0

I tried clicking on Edit and then dragging the widgets around. I also tried doing so from the System Preferences Extensions pane. And either ways, I am successfully able to change the order in which the widgets show up. However, once I restart my computer, they go back to where they were before I made the changes.

This is what my (widgets') order defaults to all the time:

Socials - Calculator - Calendar - Weather - Reminder (I have turned off Stocks and World Clock as I don't need them)

Whereas, I want them in the following order:

Socials - Reminder - Calendar - Weather - Calculator

It's mighty annoying because it's natural one would prefer to have Reminders on top of the list as it definitely has a higher priority over Calculator! Anything to fix this bug or am I the only one facing it?

1

I was having the exact same problem, and I think it started after installing an app which included a Today widget. I've finally fixed it by trying a few things, so I'm not sure what actually solved the problem. I suggest you try these things in the same order:

  1. Open the Terminal (/Applications/Utilities/Terminal.app) and paste the following lines there, then hit [Enter].

    /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/\
    LaunchServices.framework/Versions/A/Support/lsregister -kill -r -domain local\
    -domain system -domain user -seed
    

    This will rebuild the app cache, which includes all extensions.

  2. A few extensions will probably be missing now (in the Extensions preference pane). That is no big deal; just quit and open all apps that come with extensions. Logging out and back in would do the trick too.

  3. Go to System Preferences > Extensions > Today, and reorder the items to your liking. Make sure you keep all checked items together and move them to the top of the list! I suspect the Today view could get confused when enabled widgets are mixed with disabled ones.

  4. Log out and back in and see if the widget order is correct.

Hopefully, this approach works for you too.

  • You might as well ignore this answer, because today the order of my widgets was messed up again. Ugh, it seems we have to wait for an OS X Update that addresses this bug… – vbwx Apr 20 '15 at 22:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .