0

Just got myself Apple Mini DisplayPort to VGA to connect my early 2011 (pre Sandybridge/Thunderbolt) 15" MacBook Pro to Samsung SyncMaster 2494HM monitor.

The monitor is currently connected to my PC via DVI, so I wanted to use its VGA port to connect my MBP as I frequently need to use them both at the same time and want to avoid shuffling cables.

Anyway, I have a problem with making it work in FullHD (1920x1080 Widescreen, monitor's native resolution). The widescreen part in particular. Basically if I choose its native resolution it doesn't fill the whole width of the screen. When I selected it for the first time it was on full width until I clicked Refresh Rate dropdown menu - no changing involved as was only able to use 60Hz anyway). Then, oddly enough, it switched to something between 4:3 and 16:9. So everything is a bit... too narrow.

Interestingly full width widescreen works perfectly on other 16:9 resolutions, but the res is basically too low for the 24" screen.

Anyone has any idea why's that and how to fix it?

  • Have you tried using VGA at that resolution with another computer? – Ben Wyatt Jun 6 '11 at 12:17
  • Well, I used VGA port from another PC attached to the same monitor and worked well. I may have found solution to my problem, but not the cause. Still investigating. – Michal M Jun 6 '11 at 12:53
1

The solution for me was to hold down the Option key while clicking on the "Scaled" radio button in Display Preferences. That offered many more display resolutions, including widescreen ones.

| improve this answer | |
  • Awesome solution! This should be the accepted one. – Erik Escobedo Dec 21 '16 at 4:20
0

I can't remember where I found the solution for this issue, but I had to remove /Library/Preferences/com.apple.windowserver.plist and restart the machine.

This seemed to reset any remembered displays and the the resolution and aspect ration returned to normal.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .