2

Note: A question similar to this one was asked here about a week ago.

I am attempting to install Octave on OS X Mavericks. I ran the following:

brew install octave

which resulted in this error:

Error: You must `brew link ghostscript' before octave can be installed

So I followed this advice, which gave this output:

Linking /usr/local/Cellar/ghostscript/9.15... 
Error: Could not symlink bin/dvipdf
Target /usr/local/bin/dvipdf
already exists. You may want to remove it:
  rm /usr/local/bin/dvipdf

To force the link and overwrite all conflicting files:
  brew link --overwrite ghostscript

To list all files that would be deleted:
  brew link --overwrite --dry-run ghostscript

I ran the last option, which printed a really long list of files. I think these files might be related to my recent install of MacTeX, which worries me.

  • I have a similar issue (although not installing Octave, but have the brew conflict with ghostscript). You're right that it has to do with MacTex, but I am not sure the best answer, as I stumbled across this question to also try to solve my own issue. – Mike Williamson May 18 '15 at 17:48

You must log in to answer this question.

Browse other questions tagged .