43

I have a late 2013 rMBP, 13" with the following specs:

  • Processor: 2.6 GHz Intel Core i5
  • RAM: 16 GB 1600 MHz DDR3
  • Video: Intel Iris 1536 MB (integrated)

Before upgrading to Yosemite, Mavericks performed fine (everything was quick and snappy). I did a clean install of Yosemite (however, I took a bit of a strange path: reinstalled Mavericks and then upgraded to Yosemite via the App Store).

So, my problem is that the UI lags. Not immediately, but after a while (either using the laptop or have it in sleep mode and then use it) the UI gets laggy. Yosemite eats up all my RAM, and I don't really have that much apps open. Today, I had 3 PDFs open in Preview and was using Safari. Mission control and Expose were very slow and laggy.

I have already tried a PRAM reset, did not solve anything. Also reduced the transparancy, and did not work. When reading forums, it seems that Yosemite has trouble with the amount of pixels of a retina screen. A friend of mine has a 2014 11" MacBook Air (base model) which runs Yosemite fine.

What do you recommend, should I do a clean install of Yosemite again (this time using a bootable image of Yosemite)? Or is it better to wait for Apple to fix this with an update?

I'm keen for your thoughts on this matter.

UPDATE 19-11-2014: Since the 10.10.1 update, overall stability of Yosemite seems to be improved and I have not yet encountered any lag. Is it solved....?

UPDATE 21-11-2014: Still having UI lag (after clean re-install of Yosemite), though it does occur less frequently with 10.10.1. Preview also performs slightly better, as well as Mission Control and Exposé.

UPDATE 03-12-2014: UI lag is still present, and as said, it occurs less frequently. What is strange however, is that the actual performance of the machine does not seem to suffer under the lag.

  • There wouldn't be 'the' answer to this issue, so let me comment here. I have the same configuration as your mac but for 8GB of RAM. I usually don't shut down the machine for months, it usually cycles through sleep/hibernate. I shut down the machine yesterday and today the UI seems responsive. The lag is gone. However, note that after the Yosemite install, it did reboot, and the issue crept in after that. So this is just to say that a clean install may be avoided. Incidentally, my wife's machine doesn't seem to have had this issue since the upgrade. Her's is an identical machine. – Sauparna Palchowdhury Nov 4 '14 at 14:51
  • 1
    Same issue for me. I have an early 2013 model. But the problem continues even with 10.10.1. update. – Gunnar Nov 20 '14 at 18:54
  • 1
    I've got the exact same setup as you Robin, and the exact same issues. My RAM is OK, but UI has horrible lags, really stutters. Turned off translucency and it helped just a tiny bit. Waiting another month to give Apple a change to fix things before I go back to Mavericks, which worked perfectly for me. – zerohedge Nov 20 '14 at 23:16
  • 2
    One way of reducing this lag is to remove the Yosemite animations effect when opening mission control. In terminal type: defaults write com.apple.dock expose-animation-duration -float 0 press enter, then type killall Dock and press enter. If you ever need to reverse the change by going to terminal typing defaults delete com.apple.dock expose-animation-duration then running killall Dock again. – DrewT Dec 17 '14 at 18:17
  • 1
    I was able to adjust my settings like @DrewT mentioned and have to say it did help. This is not ideal and definitely an OSX 10.10 bug. – Chris Hough Jan 9 '15 at 7:21
14

I'm experiencing some slowdown after a while even on my MBA. It's exactly how you described it. It's perfectly smooth after booting the machine but eventually, after using it for one day or so the animations (especially launching Mission Control, switching between spaces and full screen apps) get noticeably choppy. I don't think there's anything that can be done about it right now, I made a clean install and even executed an Onyx automation, but the problem persists. This is clearly an optimization problem in Yosemite and I really hope it will get better with the future updates.

  • 1
    Too bad we can't do anything about it. And I hope Apple gets enough complaints about this issue. Maybe everyone that experiences this issue should report it to Apple: apple.com/feedback/macosx.html. For now, I think I'll switch back to Mavericks. I really need a reliable machine. Thanks for letting know you also experience the problem! – Robin Trietsch Nov 3 '14 at 14:08
  • Just for the record, as for reliability, I found the system itself pretty solid after a clean install, I'm not experiencing any sudden "beachballs" or freezes (I did experience some of those in Mavericks though...). The operations (e.g. launching applications, copying files, etc.) are fast, the OS is solid, only the GUI animations get kind of choppy over time. It IS definitely frustrating, but it's not something that hinders my workflow. So I'd definitely suggest that you try a clean install and see what happens. – Mr. Byu Nov 3 '14 at 15:50
  • Thanks for your reply. I'll definitely try a clean install of Yosemite first before switching back to Mavericks. I'll post my opinion after the clean install here. – Robin Trietsch Nov 3 '14 at 17:05
  • 1
    I have the same problem on 2012 MBA, but logging out and in solves the problem temporarily. Apparently, its purely a GUI problem. By the way, launching a heavy QT application like LyX invokes the problem instantly. – level1807 Nov 17 '14 at 7:58
  • @level1807, I can confirm that I seem to have started seeing this after I installed Qt SDK and ran Qt Creator for a while. – Paul-Sebastian Manole Jan 26 '15 at 12:27
11

I tried the following steps listed here:

  1. Delete /Library/Preferences/com.apple.windowserver.plist
  2. Delete ~/Library/Preferences/ByHost/com.apple.windowserver*.plist
  3. Shutdown OSX
  4. Startup, immediately press and hold the P and R keys while holding down the option (⌥) and command (⌘) keys before the gray boot screen appears, which resets the NVRAM
  5. You may have to reset your display preferences (resolution) once you login
1

Back everything up and do a clean install. I had a very similar issue... Beach balling for 30 seconds when app switching.. Clean install fixed it.

  • Maybe I'll also try a clean install. If the problem still persists, I will switch back to Mavericks. After the installation (and setting up everything on your Mac such as accounts, mail, calendar, frequently used apps and programs), you still do not experience any performance issues? – Robin Trietsch Nov 3 '14 at 14:11
  • I did a clean install and I'm experiencing something similar. Mission Control gets so slow it's not even animating anymore. – Adam Lassek Nov 7 '14 at 6:11
  • Tried a clean install, and tested performance without additional installed programs. Preview still seems to be experiencing the lag. Too early to tell about Mission Control and Exposé. – Robin Trietsch Nov 12 '14 at 7:36
  • 1
    We'll have to wait for OSX 10.10.2. .1 fixes wifi problems, but not UI lag. – Robin Trietsch Nov 12 '14 at 7:37

You must log in to answer this question.

protected by Community Nov 4 '14 at 17:51

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .