0

I receive iMessages on my iPad and not on my iPhone. I receive SMS messages on my phone but not on my iPad. This is really bad and has caused me to miss 2 work leads in the last 24 hours. Where's the syncing in that? I've read through loads of posts and what people seem to be saying is that as iPads don't do phone numbers, SMS messages will only show up on a phone. Don't ask me why iMessages can't make it to my phone too. I have spent hours trawling around and have come to the conclusion that my only option to reliably receive all messages is to turn iMessage off.

1

If I understand you question correctly you want to receive SMS and iMessages on both your iPad and iPhone. If so follow these steps.

  1. If you haven't already done so upgrade both your device to the latest iOS 8 firmware (iOS 8.1)

  2. To fix your iMessage problem, on the iPhone go to Settings > Scroll down to messages > Toggle iMessage on and enter your Apple ID credentials

  3. To get your iPad receiving SMS messages with your phone's number go on your iPad unlock it and keep it on.

  4. Then go back on your iPhone and stay on the page I told you to go in step 2 and tap 'Text Message Forwarding' you should see your iPad and any other Apple devices you have if they are on the same iCloud account (which they will need to be for this too work).

If they are: Toggle the button next to the name of your iPad and it will ask you for a code which should popup on the iPad.

If not: Go back to the main settings on the device not correctly set with iCloud scroll back up to 'iCloud' tap it and sign out if already signed in and sign in the with the Apple ID used on the other device.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .