1

My sister upgraded her 2011 MacBook Pro 15" to Yosemite from Mavericks. As far as I have been able to glean the upgrade went without a hitch, but now her computer is mostly unusable. It is very slow, to navigate about the finder, slow to open programs, and largely unhappy. She has over 100GB of free disk space and has 4 GB of RAM. Any ideas about what went sideways?

The safari crashdump is too long to post here, so I have posted it on Dropbox: https://dl.dropboxusercontent.com/u/9371124/safari_crash_dump.txt

  • Is it only Safari doing it, does it run normal without starting Safari? – Ruskes Oct 30 '14 at 20:14
  • I do not know if launching Safari is the death knell, or if the system is performing poorly before launching Safari. I was sort of hoping there was something obvious in the crash dump. – TheWellington Oct 30 '14 at 20:18
  • OK, Safari then...If you get it to Start then use the Reset Safari. – Ruskes Oct 30 '14 at 20:31
  • @Buscar Reset Safari was removed in Safari 8. – grg Nov 3 '14 at 17:31
  • in Safari 8 that is called "Clear History and Website Data" – Ruskes Nov 3 '14 at 17:37
1

The solution we came up with... the only one that worked, was to reinstall Yosemite. It seemed at the time that something went sideways with the original upgrade. Unfortunately I do not have all the details with me here.

1

This simple trick worked for me! Creat a guest account and login to that account. At first Safari should work in the new account (Since no cache, bookmarks, history, last session, etc). Then Go to Library/Safari and copy the contents to a shared folder (or pen drive). Now logout and login to your original account and go to Library/Safari and move the contents to thrash or create backup and copy the contents from pen drive to here. Try now and it should work. Later you may replace the bookmarks.plist to recover.

Note: I tried almost all of the suggestions from google search except re-install. That included removing the cache, safe boot, clearing history, extensions,...

1

Every piece of advice I used on the internet did not work. Even Apple's advice on removing things did not work. This worked.

cd ~/Library/Safari/Extensions
rm [plugins you KNOW did not come from apple]

The next part is key, in fact, this may be the only necessary step:

nano Extensions.plist

Remove everything between <dict> and </dict>.

  • This worked for me too. Deleting the history and cache.db didn't but this did. Only problem was that nanoing the file didn't work, it read the file has gibberish. I just deleted the plist and all the extensions. – orange May 31 '15 at 21:21
0

From your Safari crashdump, I found this for you that might help.

Clear the local DNS cache in OSX 10.10 Yosemite

Terminal -> Using this code: dscacheutil -flushcache; sudo killall -HUP mDNSResponder

Let me know if it helped since I do not have your problem to verify.

0

i just solved the problem. you just have to erase all history from safari, under history options tab, at the bottom is the option to erase all. hope this solves your problem too.

0

My Mac Mini/Safari seems to "hang slightly" once & awhile since the Yosemite install. If I turn-off wi-fi and back on, it "unhangs."

Try:

  1. Close Safari
  2. Trash the two Safari Preferences called com.apple.Safari and com.apple.Safari.rss.plist
  3. Relaunch Safari.

Worth a try. There is something buggy though in Yosemite/Safari.

0

Had similar problem. Try removing ~/Library/Safari directory...it should fix the freezes...it worked for me

0

I had one user whose Safari would not launch after updating to Yosemite. I ruled out problems with User cache and plist, isolated plug-ins, all the stuff mentioned above. I ended up finding a know working version of the app, from another machine, and copied over the broken app. Problem solved.

0

Check Get Info on /Applications/Safari.app. When I had problems with Safari like this, the permissions it showed 2 entries for everyone. One was set to read-only, the other to read-write. I had not seen 2 settings for everyone before, so I set the second one to read-only. Bingo – instantly everything was full speed again. I rebooted to be sure, and all is wonderful again. Good luck.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .