Since upgrading to Yosemite, Apache httpd is no longer started at boot time.

I've tried: sudo launchctl load org.apache.httpd.plist but I'm getting a service is disabled error.

I've modified the plist file and set Disabled key to NO but I still get the error. What am I missing here?

  • sudo launchctl load -w /System/Library/LaunchDaemons/org.apache.httpd.plist does that work for you
    – Ruskes
    Commented Oct 30, 2014 at 3:32
  • @Buscar웃 That did it! What does the -w switch do? Post an answer and I can mark it answered
    – doovers
    Commented Oct 30, 2014 at 3:35

1 Answer 1


I found a solution to your problem here.

Using Terminal "How do I make Apache start automatically":

sudo launchctl load -w /System/Library/LaunchDaemons/org.apache.httpd.plist

You were close to the solution just needed the -w override.

the -w Overrides the Disabled key and sets it to false.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .