0

I want to disable banners/notifications in OSX Yosemite.

The problem is the notifications keep getting reset to the default. This has happened twice since installing Yosemite on release day.

This is annoying as my work computer is showing private messages when clients are being showed something on my laptop!.

1

The above step 4 has run together and lost its formatting. You need to run it like this:

Copy and paste each line of these commands into the Terminal window, in order. Press return after each line. IN ADDITION, IN LINE 1 BELOW, YOU MUST ADD BACKQUOTES (`) (like ', but in reverse) BEFORE "getconf" and after "DARWIN_USER_DIR", so after "cd" it reads "backquote" getconf DARWIN_USER_DIR "backquote". The backquote is edited out of the lines here due to a rendering bug in the stackexchange comment system.

cd getconf DARWIN_USER_DIR

rm -rf com.apple.notificationcenter

killall usernoted; killall NotificationCenter

0

I found this on an Apple forum and it worked...

So the updated fix is: Here are the instructions I got from AppleCare from an Apple Engineer. I'm not sure if the fix was specifically for my machine or if it'll work for someone else. Follow at your own risk.

  1. Open the Library folder in your Home folder (Use Option GO Menu and open Library - otherwise it is hidden).
  2. In the now open Library folder, open the Application Support folder.
  3. Locate the folder named NotificationCenter. Drag this folder to the desktop.
  4. Next, open the Terminal application. Copy and paste each line of these commands into the Terminal window, in order. Press Return after each line: cd getconf DARWIN_USER_DIR rm -rf com.apple.notificationcenter killall usernoted; killall NotificationCenter

  5. Close the Terminal app.

  6. Restart your computer.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .