9

After updating two distinct Macs (a MacBook Air and a Mac Mini, both using the same iCloud account) from Mavericks to Yosemite, I noticed the following weird bug: All keyboard shortcuts in Safari and Firefox (not in Chrome, nor in any other app I've tried) have stopped working. When using a shortcut in Firefox, the corresponding spot on the menu bar is briefly highlighted (for instance, ⌘T flashes File), but nothing else happens; in Safari, not even this menubar flashing occurs.

Weirdest of all: on both browsers, if I first open a menu by clicking on the menubar, then any shortcut works (while the menu is open).

Question: Has anyone else encountered this bug? What would you recommend? Should I notify Apple somehow?

  • 1
    I have this problem as well. It seems to be related to something in my user account data, because I've tried reinstalling Yosemite, and that did not fix it, but when I tried to create a new user account, the problem went away. I'm halfway considering starting a fresh account, but there's just so much work involved with that, so I'm hoping that I'll be able to figure out what triggers this. – mikl Oct 31 '14 at 22:24
8

I have had this exact problem for weeks, and it's been driving me crazy, but I've finally found a solution. I found this thread on the Apple Support Communities, where “stevendeluxe” says the following:

Problem fixed! I compared the system preferences for each user and found out that I had several languages activated in the language/region settings. So I deleted the language adding the option "list sort order". This option wasn't activated in my test account.

You have to try which language is the "bad one" on your system (In my case it was "german"...haha) and delete it. UPDATE: I've tried to re-add the deleted language and still safari works fine.

I did the same, went to “Language & Region” in OS X System Preferences (found in the Apple menu at the top left of the screen), and removed two languages I'd added as a lark (Swiss German and Klingon, to be precise), and after restarting the computer (which OS X requires if you remove the primary language), all my keyboard shortcuts work again. Joy and jubilation.

I hope this works for you, too.

  • Thank you so much! I did not even need to remove the "fun" language; moving it down in the hierarchy so that it would not be the system's primary language did the trick. I still think this is a serious bug – there's no reason why language settings should interfere with keyboard shortcuts – but at least it's solvable in my case. – fudo Nov 6 '14 at 11:31
  • I wonder why I could not find that thread by myself. I looked on Apple forums before posting here but found nothing, yet apparently that thread was already there on Oct 20. I guess I have to get better at googling. – fudo Nov 6 '14 at 11:37
  • More than a year later, the bug is still present, and your solution still applies... Thank you! – François POYER Nov 25 '16 at 13:43
  • Bug still active (in Sierra) and your solution still works! Thanks a lot – Pit Feb 17 '17 at 14:27
1

My problem was Command-Shift-Option-V (Paste and Match Style) which would just give me right-pointing double angle quotation mark ('»').

Per my experience there may be at least three things that might have something to do with this apparent bug (2011 Early MBP with SSD and did a clean Yosemite install by the way if anyone's wondering).

  1. You have only one system language selected (in my case a minor language like Finnish).
  2. You only have created a single user account.
  3. You log in automatically.

Merely adding and setting English as a primary system language didn't solve this issue.

It seems that only after I had created a new temporary user account, logged in with that user AND/OR optioned out to log in automatically, things finally went back to normal.

The bug didn't return after I had deleted English system language and switched back to Finnish. Nor when I deleted the temporary new user account. Or when I reverted back to automatic log in.

For future reference I think it may be a wise decision to hold on to the English system language (even if you will never use it)...

  • Just thought to add that everything's back to normal except for one exception: I still get a right-pointing double angle quotation mark ('»') when I try to Paste and Match Style (Command-Shift-Option-V) but ONLY if I use Safari browser with Google Drive documents. This key combination works as intended if I use Chrome browser instead. So, for me it's real simple: it's Apple deliberately crippling a workflow to discourage people using Google products with Apple designed Safari browser. I'd love to be proven wrong of course... – stupidus Jan 19 '15 at 6:27
0

Yes I have the same problem. Not all shortcuts are affected but the most useful and ordinary ones (cut copy and paste for example) are. Really irritating as I prefer using keyboard shortcuts

  • 3
    Actually, he question asked if anyone else encountered the bug. This answers that. – Daniel Oct 30 '14 at 12:08
  • Yes, I agree that technically this answers my question; at least now I know I'm not crazy or cursed… – fudo Oct 30 '14 at 23:00
0

I see this problem with Firefox version 34.0.5 on Snow Leopard. For me, the non-working function is "Email Link..." on the File menu. I created a keyboard shortcut for that item. When I press the shortcut, the File menu blinks, but the desired function does not fire. However, when I click to open the File menu first, and then press the shortcut combination, the item is activated.

The language-related fixes suggested previously have no effect in this instance.

-2

System Preferences -> Language & Region -> Keyboard Preferences -> Keyboard -> select the "Use all F1, F2, etc..." This toggles between the normal and the special features of the Function keys.

  • 1
    This really isn't an answer to the question asked. – Tetsujin Jan 23 '16 at 10:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .