6

Since updating to Yosemite, Finder has been acting strangely. I can usually get it to show a normal-looking and -behaving window for a few operations, and then the window will either:

  1. Be blank, showing no files or folders where I know it is pointing at a non-empty folder.

  2. Show prior state, rather than the state I know to be true now. For instance, I could delete a folder, but it still shows as present, even after forcing Finder to refresh the view somehow.

  3. Double the labels under the finder item:

    doubled Finder text

The only third-party extensions showing in the "Extensions" system pref pane are Dropbox and PCalc.

I've read that old versions of Rogue Amoeba's "Instant On" feature can cause Yosemite problems, but I'm on the current version, 8.0.2.

I can fix it temporarily by dropping to the Terminal and saying killall Finder.

  • You are not alone! And I don't have "Instant On", I don't know what that is. I have Dropbox though. – Matthieu Napoli Oct 31 '14 at 5:56
-1

You have to make a PRAM reset.

To do that restart your Mac, and BEFORE the "Bong" press ALL the following keys, until you hear the "Bong" again : cmd + alt + P + R After your can let your Mac start normally.

If the problem persist, redo the manipulation but stay your finger on the key until you have hear the "Bong" 5 times.

  • This symptom eventually went away on its own, probably as part of the 10.10.1 update. While it is possible that the update initiated a PRAM zap to achieve the fix, I suspect it's more likely a case of brokenness introduced in 10.10.0 that didn't take 5K iMacs into account. – Warren Young Aug 29 '15 at 22:07
  • Indeed the latest version of Yosemite fix the problem. In 10.10.0 I had the same problem as you and the only solution which worked for me was the PRAM reset. – Thibault Aug 29 '15 at 22:10
  • What, are you going to recommend that I fix permissions next, too? Throwing out generic "Try this and pray" fixes is not answering the question, it's voodoo. Do you know for a fact that the original problems were due to PRAM corruption, or are you just guessing? – Warren Young Aug 29 '15 at 22:12
  • I'm not sure but as the only worked solution was to reset the PRAM, I think it was a PRAM problem which was fix in the following updates. It's a good thing to fix permissions with Disk Utility before and/or after a system update – Thibault Aug 29 '15 at 22:14
  • -1: PRAM reset is not the answer to everything. Actually it's the correct answer to hardly anything. Additionally: What make you think that resetting it multiple times changes anything different? – Max Ried Mar 27 '16 at 9:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .