Hello I have a new iPad 2 and two wireless networks at home. I can only connect to the one from my Actiontec DSL router, not to my Linksys WRT320N. I have followed all the steps on http://support.apple.com/kb/ts1398 and cannot get it to connect. My iPhone and other laptops connect to this network just fine. I have tried setting the router in N, and B-G Mixed modes. I have the network set up using WPA2 Personal and have tried it with encryption turned off too. I have reset everything.

Any other ideas for troubleshooting?


Even if you get it to connect finally to your network, given the trouble you are having now, you will also probably end up with the wifi drop problem.

There is currently no solution to it other than turning off your wifi and reconnecting or deleting your network settings and reconnecting. Apple has not to date done anything to correct this problem (you can search around and find lots of people complaining about this one).

If you're still in your return period, you might want to think about taking the stinker back and getting a tablet from a company that can at least get the basic telecommunications functions of their tablet right.

  • Uuuh huh. Very helpful. The iPad is the best personal computing device I've ever used. But, I can imagine I would be very upset if I wasn't able to get any wifi at all. – sirtimbly Jul 8 '11 at 15:14

Do you have MAC address filtering enabled on your Linksys? On more than one occasion when I did, I screwed around with a new device for an hour before I remembered to enter its MAC address to the router.


One suggestion is to check that the DHCP scope range of your WiFi router has enough IP addresses in the pool for an additional device. Out of the box most routers obviously have defaults of many IPs but it's easy to set it to only a few IPs available when locking down you home network but then forgetting about the limited IP range a few months later.


Assuming the article was followed to the letter, including resetting Network Settings, I have to ask: Does the iPad see the network in question? How about other networks?

If yes to both, and you're fully up to date in your firmware, then you've actually exhausted all suggested troubleshooting steps, short of restoring the device in iTunes, and the obvious restart and hard reset options previous to that.

  • The iPad does see the network, and gives me a password prompt which I enter and click Join, but then it alerts - Unable to join the network "Magnum" – sirtimbly Jun 5 '11 at 22:40
  • It sees all networks, and is up to date. I did all the steps in the article except updating my router firmware... ugh, I suppose that's next. – sirtimbly Jun 5 '11 at 22:41
  • So if the iPad can connect to other networks, then yes, router firmware is a good call, as the next step would be restoring the device. – David Metcalfe Jun 5 '11 at 22:44

Linksys routers allow you to enter capital letters in the SSID. Some devices won't connect to a wifi network though when it has a capital letter in the SSID. Remove the capital letter and everything works fine.

  • Clarification: Some devices won't connect to this particular router WRT320N when it has capital letters in the SSID. – sirtimbly Sep 2 '11 at 1:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .