13

In OS X Yosemite, a new feature is that when you double-click on the title bar of an application window, the window will maximize: http://osxdaily.com/2014/10/28/maximize-zoom-windows-os-x-mac/

Is there a way to disable this behavior? I am accidentally double-clicking and maximizing terminal and VirtualBox VM windows, and this sometimes causes problems.

  • I have been trying to figure how to disable this feature and it seems that double click either maximizes or minimizes, and nothing in between. – Zlatty Jun 16 '15 at 18:24
8

While I haven't found a way to turn it off completely, you can make it minimize instead by enabling:

System Preferences > Dock > Double-click a window's title bar to minimize.

  • 6
    Worth noting that in the same location it's now possible to turn it off completely. – Dave Sep 10 '16 at 15:38
3

If a third-party solution is acceptable, the free BetterTouchTool allows you to change the effect of this action.

Here is how to disable the maximize action:

screenshot

If you'd like to keep the functionality, and just want to avoid accidentally triggering it, consider setting up an action for double-clicking the titlebar while holding a modifier key.

2

Jacob had it right - in this system pref area you can simply uncheck to box, disabling both double-click to minimise & zoom.

System Preferences > Dock > Double-click a window's title bar to...

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .