I'd like to use Inconsolata as the closest free approximation of the Consolas font for editing and programming on my Mac. After downloading Inconsolata's OpenType file I changed TextWrangler's preferences so that Inconsolata becomes the font for the editor window.

This worked just fine and the text is now properly rendered using Inconsolata. I take that as a proof that the font is properly recognized by the OS in general.

Then, I tried to tweak Terminal's preferences to also use Inconsolata. To my surprise, the Terminal window shrank to this:

Terminal after applying the Inconsolata font

For a test, I tried to increase the font size to 288 in order to check whether the text is simply rendered really small and therefore seemingly creating a blank window. Unfortunately, to no success.

I tried to switch the fixed-spaced font in Mail and as the result, a mail window that previously displayed a message just went blank. I tried TeXShop and was able to successfully changing the editor font to Inconsolata.

It seems as if the change works well in some apps and fails entirely in other apps. Does anybody have an idea why this is the case?

How can I use Inconsolata in the Terminal (and Mail) under MacOS X 10.6.7?

  • Have you tried to Validate Font in Font Book? Commented Jun 5, 2011 at 19:42
  • Yes, I did a validation of the loaded font in Font Book and all went well. According to Font Book the font is safe to use. Commented Jun 6, 2011 at 3:41

4 Answers 4


Try to clear and rebuild your font cache with the following:

sudo atsutil databases -remove
sudo atsutil server -shutdown
sudo atsutil server -ping

The above is "my standard answer" to font problems.

After your reply, I tried to download the font too. Installed it and in the Terminal.app got the same result as you. So +1 to the question - I'm interested too.


  • removed the otf version (does not work)
  • I downloaded the ttf version from the Google Fonts Directory
  • removed my cache as above
  • installed the ttf version
  • and works.

after it, for the test:

  • removed the ttf version
  • cleaned the cache
  • installed the otf version
  • does not work

so again for ttf - and have a working version in my Terminal.app

Haven't any idea why the otf version does not work. ;(

  • Thanks for your response. I tried but did not succeed. The problem still persists. Commented Jun 6, 2011 at 3:46
  • Confirmed, the TTF also works on my computer. OTF doesn't. Strange, but at least I'm now able to use the font. +1 Commented Jun 6, 2011 at 16:20

I can't reproduce your problem on my Mac (10.6.7). I downloaded the "OpenType file", opened it, installed it into Font Book, and configured Terminal to use it without incident. Maybe try deleting the font from your system and trying again?

  • Thanks for the reproduction, even if it yielded a different result. Yes, I tried to remove the font and then reinstalled it without no luck. Commented Jun 5, 2011 at 19:01
  • @Uwe I tried Inconsolada in Mail as well, and it worked without a problem. I played around with different sizes, font smoothing, etc and I can't reproduce your problem. Commented Jun 5, 2011 at 19:07
  • If the issue persists even with the font cache rebuild, you could try a Terminal.app alternative like iTerm or GLTerm and test further. Commented Jun 6, 2011 at 1:42
  • I can also confirm that I can use Inconsolata in Terminal without incident. It also works fine in iTerm (which also has a few other nice features), so that might be your next step to see if it is just specific to Terminal or something else is going on. Commented Jun 6, 2011 at 3:02
  • @Kyle Cronin - can you please tell me, than the font is shown in the "Fixed width" fonts? (in the Font panel, like Monaco or Courier?)
    – clt60
    Commented Jun 6, 2011 at 15:25

Apparently there is a problem with OpenType fonts in Terminal since Snow Leopard. See this thread on Apple Support: https://discussions.apple.com/thread/2775619?start=0&tstart=0


there's a pretty simple solution for this problem.
Just convert the .otf file to an .ttf file.
I used FreeFontConverter for that and now inconsolata works in my Terminal.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .