2

Since I upgraded to Yosemite a couple of days ago, I’ve had a problem with the Mail app.

Whenever I click on the “Drafts” or “Sent” folder, the app hangs (i.e. won’t accept any input), beachballs, and seems to stay like that until I force-quit it using the Finder (I’ve left it for a few minutes and haven’t seen it crash of its own accord yet).

I’ve tried removing my one third-party add-on (SpamSieve), removing Mail’s saved state, and removing Mail’s container folder, as described here:

I’ve also tried disabling my primary e-mail account (which is with FastMail). After doing that, I no longer have a drafts folder, but clicking on the “Sent” folder still triggers the bug.

Here’s a description of what appears to be the same problem on Apple’s discussion forums: https://discussions.apple.com/thread/6623206?start=0&tstart=0

How can I fix this?

2

I had a couple of e-mail accounts still set up in Mail which no longer existed on my mail server. I disabled these in System Preferences > Internet Accounts, and since then (which is admittedly only three minutes), I haven’t been able to reproduce the bug.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .