13

This only happens to me on Yosemite. I gave Steam access as per my previous question. Steam worked fine until the upgrade to Yosemite. What may have changed, and has anyone a clue how to fix that without deinstalling a few terabytes of video games?

9
  • Is Steam allowed in your Firewall ?
    – Ruskes
    Oct 28, 2014 at 18:00
  • @Buscar웃 actually, FireWall is off.
    – Kheldar
    Oct 28, 2014 at 20:34
  • It should be not off for other reasons! Open it and add Steam to the allowed!
    – Ruskes
    Oct 28, 2014 at 20:43
  • 1
    @Buscar웃 the machine is behind a dedicated firewall and IDS. This should not be a problem. I'm more curious of the reasons why you think the FW could be involved with the Accessibility Features request?
    – Kheldar
    Oct 28, 2014 at 21:12
  • 1
    Steam is doing this for me as well. I assume Steam just needs an update for Yosemite.
    – Chris A
    Oct 28, 2014 at 22:28

2 Answers 2

12

A temporary fix (requires terminal):

  1. sudo sqlite3 /Library/Application\ Support/com.apple.TCC/Tcc.db 'delete from access where client like "%Steam%"'

  2. Restart Steam

  3. Allow steam access in accessibility via UI or something like: sudo sqlite3 /Library/Application\ Support/com.apple.TCC/TCC.db "INSERT OR REPLACE INTO access values ('kTCCServiceAccessibility','com.valvesoftware.steam',0,1,0,NULL);"

5
  • 1
    Thank you for this, a very interesting insight on how the privacy database actually works under the hood. There apparently also is a tool called tccutil, but I did not look into it.
    – Kheldar
    Nov 3, 2014 at 7:26
  • why is this a temporary fix?
    – tedder42
    Nov 4, 2014 at 18:15
  • I'm not entirely sure but a lot of configuration changes made by some apps (specifically tanium which is used to monitor company issued computers) will cause these settings to change frequently and they do that by directly modifying this database... and they don't always do it correctly. Chances are that you have something on your laptop that is editing this in one way or another and it's a matter of time until you need to run the commands again. A better fix is to go through the API and get all the right parameters set... I don't know how to do that though and this quick and dirty hack works. Nov 5, 2014 at 8:29
  • Y'all need to upvote this hack though :P, gotta reap that karma. Nov 5, 2014 at 8:32
  • +1 - This seems to be a general solution to accessibility features access problems. Worked for Logitech software as well.
    – andrewb
    Sep 15, 2015 at 22:58
3

This seems to be a known bug for Yosemite.

Steam has to be updated to work 100% with compatibility for Yosemite. Just wait for them to fix it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .