3

I use a 13 Macbook with a thunderbolt display on Yosemite. Since the installation of last osx version, if I try to open Time Machine I can only see a completely black screen on laptop screen. The other screen remains with previously opened windows. So, time machine is completely unusable. I can only use ESC to exit.

Any ideas of what can be happening here?

If I don't connect my second monitor, works fine.

This is my displays configuration: enter image description here

0
2

If you have this issue using Yosemite, i found a turn around:

  1. Go to Preferences - Mission Control
  2. Uncheck "Displays have separate Spaces"
  3. logout and login

This will fix Time Machine to display black screen in one monitor. The side effect of this is you loose the abilitty to use monitors as separate spaces but isn't that bad.

1
  • What also might fix the issue is opening Mission Control and close the extra desktops (hit the x icon in the corners). Then open Time Machine and the interface should display. – Jason R Jun 4 '15 at 3:19
2

Unplugging my second display 'solved' the issue. Not ideal, but an adequate solution for me to get into Time Machine quickly on the odd occasion.

0
2

Yes, the issue seems to be with handling multiple monitors and spaces. I found a surprisingly simple workaround, that worked for me, without switching anything on and off, rebooting or changing settings permanently:

  1. Go into your System Preferences, Choose Displays and check the button for mirroring your two monitors (for procedure see Apple's instructions under Arrange your displaysenter link description here)
  2. Enter your Time Machine and do what you have to do.
  3. When you are finished, uncheck the Mirror displays button.

That's it. Curious to know if it worked for others?

If it did, Apple might think of just doing that. Besides, re-experimenting the past with two exactly identical images somehow adds to the mystique of the experience.

0
0

Yes, happens identically to me. As the second monitor is operational try ESC (if not, hold the off button for three seconds, the option menu will appear on your second menu, click sleep then space bar to exit sleep and primary monitor will return). Now switch off and unplug the secondary monitor, try again, voila, all (should) works fine.

0

Running OS X Yosemite on a Mac mini and simply hitting the off button on the secondary screen worked just fine. No need to unplug or logoff.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .