127

This is a follow up to So my Yosemite install is slow - what to do?

Since installing Yosemite a week or so ago my machine is very sluggish. I am a web developer so I change windows/apps a lot. Changing apps makes my machine hang for 2 or more seconds.

After observing the Activity Monitor I can see that WindowServer is taking up a lot of CPU when I move windows and also when I am just using one app. I have tried closing apps to determine which, if any, is causing the issue but haven't come up with anything useful yet.

Here is an example.

Activity Monitor showing WindowServer at 37.6%.

Even right now as I type is flips between 10% and 20% usage. I am only typing!

How can I fix this?

10 Answers 10

91

I had a similar issue with high cpu usage in WindowServer which I managed to get back to something more normal by removing any items in my menu bar that were making high frequency drawing updates.

In my case it was the Network Monitor from Little Snitch that seemed to be the biggest culprit.

  • 17
    This was my issue as well. Crash plan and little snitch both draw to the menu a lot. Disabling the animations helped. – afuzzyllama Dec 4 '14 at 19:43
  • 5
    Oh god, thank you... disabling the Network Monitor worked for a while, but it all started again. After setting the icon theme of CrashPlan to "No animation", everything is as fast as it should. – Strayer Dec 17 '14 at 22:28
  • 1
    I've been experiencing issues where my entire WindowServer starts to spike, slowing my computer down considerably after opening and using a large PDF in Preview for a while. After I logout and login, it's all fast again (This is with little snitch network monitor running in the menu bar as well). – film42 Dec 19 '14 at 5:00
  • I can confirm the PDF issue. Also little snitch seems to have an impact - will watch it closely from now on. – binaryanomaly Dec 30 '14 at 18:51
  • Animated menubar items was the culprit in my case as well. Disabling the MozyHome menubar item reduced WindowServer CPU from nearly 70% to ~5%. – gskinner Feb 10 '15 at 18:18
26

From what I've collected yet, the following might be able to help you (find my personal experiences in italic):

  • Mission Control: switch "Displays have separate Spaces off", switch Dashboard off. Dashboard as an overlay really slowed things down for me
  • Fix disk permissions, reset System Management Controller, reset PRAM (Luis Mercado explained this well at https://discussions.apple.com/thread/6623697). I had some minor success with this, but the issue started occuring later anyway
  • Reduce transparency effects (it's in System Preferences > Accessibility under Display). I've tried this, it might improve the performance but I was missing the look so I've switched it back.
  • Switch off automatic graphic switching (System Preferences > Energy Saver). This was the best option for me, as I don't really worry about energy consumption, but honestly I don't think that there should be a real need for this.

I'm not yet aware of a real solution yet, let's hope that Apple will fix this in 10.10.1.

edit: I've updated to 10.10.1 and the issue still persists, so I guess we will have to wait longer or go with the reinstall.

edit 2: Switching to El Capitan has vastly improved this, so for me, this is no longer an issue.

  • Thanks I will try that. Are you having the same issue? – Jake N Nov 5 '14 at 7:02
  • Yes, I am... Please let me know about what seems to work for you, I'm interested. – Scorchio Nov 6 '14 at 11:15
  • 1
    So far I have tried your ideas, but that was after reinstalling OSX. I did that via Recovery mode. I reinstalled OS X, I didn't format and reinstall - as thats a real pain. I just reinstalled OS X and that seems to have helped a lot so far! – Jake N Nov 6 '14 at 16:48
  • Awesome. Simply switching off Dashboard and "Displays have separate Spaces" did wonders. I really used to suffer on my 2013 Air, and now it's like a completely new machine. – villapossu Dec 11 '14 at 13:36
  • 1
    Things seem to be slightly better with 10.10.2 beta, but still having some real issues at various times with application switching and cursor lag on bluetooth as well as a lot of Spotlight activity. Also Safari is still a little slow + big black "boxes" appear in Safari from time to time (same as in x.0 and x.1). Any luck on your end? – ylluminate Dec 13 '14 at 22:05
13

Disable the "Display have separate Spaces"

Hi, try this: Disable the "Display have separate Spaces"

LogOff and Login again, check the process...

all fine?

  • 1
    Your suggestion has improved my situation, but haven't solved the issue completely... – Scorchio Nov 4 '14 at 16:28
  • I am same, it helped a little. But its still terrible. – Jake N Nov 16 '14 at 15:44
  • This isn't a solution to people who use multiple displays. Having only single menubar is like going back to Leopard or Lion. – Krystian Apr 6 '15 at 20:09
  • Well, this fixed the cursor lag problem on a 2011 I7 MacBook Pro using the main display and a Hi Res 2nd display. Very nice, thanks – ort11 Sep 3 '15 at 15:05
  • This worked fine for me, unchecking the 'Displays have separate Spaces' has improved notably the performances. I'm on a 2012 i7 MBP Retina. – Valerio Schiavoni Sep 8 '15 at 15:43
9

I deleted my old answer since it had turned out to be only a temporary fix (if even a fix at all). Today I found something that cleared up most of the slowness for me which I describe in detail in this link:

Yosemite: Accessibility zoom + multiple monitors = poor performance

Somehow my user preference file, com.apple.sidebarlists.plist, had acquired several keys with very long values (all named Bookmark); the lengths ranged from about 2.7 MB to 4.3 MB which made the size of the preference file larger than 11 MB. It appears that whenever an operation occurred that needed to access the (sequential) preference data from that file, reading the entire file brought everything to a near standstill until complete. (When I was looking at the file with an editor I experienced the same slowness in moving through the file.) Removing that file has eliminated nearly all the slowness that I was experiencing since switching to Yosemite and continues to do so.

I do think we're dealing with several different issues that are causing Yosemite to slow down and any of us may have one or more of these issues. I'm still seeing long dumps of trackpad gestures in my system log which I had felt was the cause of the slowness but now appears to only slow things down at certain times (as well as cause Firefox's scrolling to fail) after using Firefox for a while; the rest of the machine seems back to it's normal speed.

If anyone finds the same thing and, if so, removes this preference file then it would be good to either validate or invalidate this as a possible cause since the solution is so seemingly elusive so far. This change has made such a dramatic difference in using Yosemite for me that I hope this is a solution for many others suffering from the slow down since upgrading to Yosemite.

  • OK it's still early days, but so far it seems this has really made a difference. Thanks! – Alastair Jan 17 '15 at 16:04
  • @Alastair - I found that it took me several attempts to keep the bloated keys out of the sidebarlists pref file (maybe due to caching and not being sure when the file was actually rewritten) but I haven't seen the problem recur after many weeks of use and it did help me significantly. One other thing that I found helped keep it from returning was to clear the Recent Items menu as in my case many of the problems were associated with Recent Servers. Hope it helps you. – Zhora Jan 21 '15 at 21:41
  • After experiencing several months of every degrading Yosemite performance, this finally worked. Everybody experiencing this problem should submit a bug report to Apple through bugreport.apple.com – Ricardo Sanchez-Saez Apr 30 '15 at 16:07
  • I'm now running 10.10.3. Once I got to 10.10.2 the bloating of the files seemed less of a problem but sometimes still there. It continues with 10.10.3. From what I can see it usually happens when I connect to my partner's Mac and have his disk in my sidebar or it shows up in the Recent Items list. The last few days I seem to be getting slowed down once again when it bloats. I quit the finder and remove the pref files and they return small until the networked disk is back. I'm gathering details for bugreport; post details if you find specific things that seem to cause it. – Zhora May 1 '15 at 17:05
6

My machine has the same problem, what I did is uninstall the Google Chrome, and then everything goes smoothly.

It might not help you since you are a web developer and may rely on Chrome

  • 1
    For me it is also caused by Chrome. Once I close it, the CPU usage of WindowServer goes below 5% in average. – maremmle Dec 19 '14 at 22:12
  • Quit chrome, re-open and click cmd+shift+t to regain all tabs if those are closed. That's solution for me. Submitted issue report to Chrome, you should all do the same so Google will get noticed and fix this. – Lukas Jul 5 '18 at 8:21
4

Here's what worked for me:

  1. if you've got a second screen attached, disconnect it, reboot, reconnect

  2. Close Google Chrome

  3. Still no good? Try this https://discussions.apple.com/thread/6623697

3

for me, the culprit was using Yosemite's new system wide dark mode (Systemsettings->General->use dark status bar and dock). Switching back to bright mode reduced the load of WindowServer for me from >100% to 2-7 %. So if you enabled that, check for that. ;-)

  • Which app was that in? – Jake N Feb 2 '15 at 9:53
  • it is system wide as of Yosemite. System settings->General; Nothing application specific – Hug Feb 2 '15 at 10:03
  • Ah right. That's why I can't find it. I'm back on the old version now. – Jake N Feb 2 '15 at 10:42
  • strange. i switched dark mode off, and windowserver's cpu usage dropped by about 33%. i turned it back on, and it remained low. now i'm wondering if it will climb back up if i leave it in dark mode. guess i'll find out. – bunnyhero Apr 15 '15 at 0:22
2

CrashPlan Tray is definitely one culprit for high CPU usage. It helps to disable animations in the tray preferences.

But it still did not solve the problem for me. The only thing that solves it for perhaps a week seems to be a full reboot. After that the machine simply becomes sluggish, and needs to be rebooted. Back to Windows95 yay! Apple should do something about this – but no, the problem seems to have been around forever. At least they should provide instructions/application to debug this and find the external culprit, if it is an external application. But I'm increasingly beginning to think it is is mainly WindowServer getting tangled up with itself, exacerbated by other applications' task bar updates etc.

2

I used to experience this problem, until I upgraded to OS X 10.10.2. Now I can go for weeks without rebooting, and the window animations will stay smooth, and the WindowServer process will not use a lot of CPU.

  • Is that a recent update? – Jake N Feb 26 '15 at 22:31
  • According to MacRumors, it was released on January 27, 2015. – Elias Zamaria Feb 27 '15 at 18:19
1

As mentioned by most of the answers, it may be due a menu bar item of yours.. I was experiencing the same behavior and removed iStat Menu bar as well as Little Snitch and after that the situation improved significantly.

You must log in to answer this question.

protected by Community Dec 1 '14 at 11:33

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .