In OS X Yosemite and OS X El Capitan, when starting Google Chrome or Mozilla Firefox, there is an invasive, annoying, and persistent notification, titled "Try the new Safari."

There is only two options in the notification.

Clicking on "Later" will have the same notification come back next time, and "Try now"… well, I dislike being forced to do things on my own computer.

This notification reminds me of the annoying popups coming in another famous operating system, Microsoft Windows, and this is one of the many reasons why I am not using it anymore.

  • Annoying notification

Is there any way to get the notification to not show up anymore without actually trying Apple's Safari?

  • 4
    ... you could just try it, once. – Tetsujin Oct 29 '14 at 9:21
  • 1
    For those interested in editing the plist: Try support.apple.com/en-au/HT202292 under "Editing property lists" – Steven R. Dec 5 '14 at 10:25
  • 2
    This caused a major issue for my girlfriend and her computer illiterate mother. We used to use chrome remote desktop to help her with issues, now she accidentally switched to safari via this annoying popup its a been a pain to help her. – clocksmith Apr 4 '16 at 0:28
  • @Ironman well the question asks how to disable the notification without using safari... – Ring Ø Jan 18 '17 at 1:25
  • 1
    @Tetsujin Already have tried it and decided not to use it. – J.Money Nov 23 '17 at 20:20
up vote 30 down vote accepted

You can get rid of it without giving in to Apple‘s desire for you to “Try Now”. Even if you click the button, they will ask you to change your default and may still ask again at a later time. I have explained it in much greater details on my blog but the gist of it are these three commands:

defaults write com.apple.coreservices.uiagent CSUIHasSafariBeenLaunched -bool YES
defaults write com.apple.coreservices.uiagent CSUIRecommendSafariNextNotificationDate -date 2050-01-01T00:00:00Z
defaults write com.apple.coreservices.uiagent CSUILastOSVersionWhereSafariRecommendationWasMade -float 10.99

You must log out and in again for the change to apply. You should actually do it immediately to prevent the system from reverting the changes.

I also cover how to stop Safari from prompting you to become the default every few days. (epimorphic touched on this briefly.) Interesting if you need to use Safari on occasions for site-compatibility, testing, or whatever reason. (Oddly enough, I have not heard any automated browsing test suite authors complaining about this yet.)

  • 4
    Thanks. Incredible we have to come to that level of complexity to remove that annoyance. Does OS X take the Windows route? Great blog btw. – Ring Ø Dec 9 '14 at 23:54
  • 4
    Is setting CSUIHasSafariBeenLaunched to YES necessary for your method? Call me petty, but perhaps we could deny Apple even that miniscule victory :P – epimorphic Dec 18 '14 at 19:50
  • 1
    @epimorphic it is actually not strictly required. It is just an extra measure to try and keep the thing from popping up again at a later time. – Aeyoun Dec 21 '14 at 22:55
  • 5
    @Aeyoun I contacted Apple support in this matter, because I thought, if they hassle me with something like that, I at least bother them as long as I can with it, and maybe they even come up with a solution. Which they didn't! At first the guy suggested to actually try out the new Safari. When I ask how about deinstalling it he said he would not recommend it. At further inquiry he then said that 'since Safari is built into the system and is interwoven with everything, he strongly advises not to deinstall it'. – atripes Feb 5 '15 at 16:26
  • 1
    @atrioom, you get the same warning when trying to uninstall the Chess.app. I doubt its that interwoven. ;-) The arguments you were given sounds like those from Microsoft when asked by the European Commission to unbundle Internet Explorer from Windows. – Aeyoun Feb 5 '15 at 17:24

I may have found a solution. Go to System Preferences, then notifications (first line), scroll down to Safari and disable "Safari alert style". Since I did that, it's stopped popping up...(then at least so far) Hope it'll help you.

  • 2
    I got the alert for the first time today after I restarted Chrome. I went and checked the setting you suggested but it is already set to "None" and all the other settings are all off too. Safari is in the bottom section under "Not In Notification Center" already. – alimbada Nov 12 '14 at 1:50
  • 1
    The notification comes from the UIAgent service (not listed in Notification Center) and not Safari itself. This will not work. – Aeyoun Dec 9 '14 at 17:44

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.