9

When I attempt to set the Show Desktop hotkey inside of Mission Control to a mouse button it never seems to work. My preferred mouse button would be mouse button 4 (which is a little thumb button on the side of my mouse).

enter image description here

This used to work brilliantly but at some point it stopped. I believe this whole thing started with Leopard, so i've been seeing this behavior for quite some time.

I can set any other Mission Control shortcut to Mouse Button 4 and it works great. The Show Desktop shortcut does not work with any mouse button. The keyboard shortcuts work for everything though.

I'm not the only person to have seen this issue either. Here are some other people who experience my problem or a suspiciously similar problem.

http://forums.macrumors.com/showthread.php?t=1369627

'Show Desktop' Mission Control/Expose Not Functioning

https://superuser.com/questions/320208/show-desktop-mission-control-expose-not-functioning-osx-10-7-lion

Someone suggested removing the ~/Library/Preferences/com.apple.symbolichotkeys.plist file which did not work for me.

I have a MacBook Pro (Retina, Mid 2012) and a Logitech G9 mouse. I would love some insight on how to fix this issue.

3

SOLVED IT! (At least for me...)

I'm using a Logitech Anywhere Mouse MX, and was having the EXACT same problem not being able to assign Show Desktop, Mission Control, etc., to the mouse buttons from the System Preferences-> Mission Control area as I had previously. The reason is because I had installed Logitech's proprietary Control Center software which overrides selections in System Preferences -> Mission Control.

Simple Fix: Go to System Preferences-> Logitech Control Center Logitech Control Center

From here click on the image of your mouse that appears on the screen, which will make available the "Configure..." button, upon which you should now click. Mouse Photo Page

On the next page, this is where the magic happens! You see the available buttons on the left side of the screen, and the actions you are able to assign to those buttons on the right side of the screen (Assigned action). When you click on an action item in the right column, a drop down menu appears allowing you to choose which action or area of action you want assigned to the corresponding mouse button in the left column. Choose "Mission Control".

When you do this, the bottom half of the screen will give you radio button options to choose which specific action within "Mission Control" you want to assign to that mouse button, such as "Desktop". In the attached picture on my next post, you will see that I have opted to assign to my "Thumb Back" button the "Mission Control" radio button.

And that's it!

While it was annoying at first not to be able to assign actions to my mouse buttons from the original Mission Control area in System Preferences, I have found I much prefer there Logitech Control Center as I don't have to guess which button corresponds with "Mouse Button 4" or "Mouse Button 6", etc. The actual button names, along with their representative icons are used in this new location, and, as before, the moment you assign an action to a button, it works. You don't need to close the window for your selections to take effect, which is as it was before, and quite wonderful.

Hope this helps!!

0

It's long overdue – I hope you've been able to fix it – but for future generations, deleting

~/Library/Preferences/com.apple.symbolichotkeys.plist

rebooting, and setting it up again should help.

However, another reboot will break it again so either a) only put the computer to sleep, which many do regardless, or b) download a utility such as USBOverdrive and use it to invoke a key press configured to Show Desktop using a mouse button (or Show Desktop itself if the utility supports that option).

  • I haven't yet, I will try this and let you know though. – Xealot Jan 11 '15 at 16:38
  • @Xealot It's the first one, but the celebration was premature – a reboot reverts it. Seems like Apple don't care but I've been able to bypass it by assigning F11 to Show Desktop and then using USBOverdrive to invoke F11 with a mouse button. It's weird, but it works. – Harold Cavendish Jan 13 '15 at 10:25
  • 1
    One more thing I'd like to add to this - and I think it works: 1) remove com.apple.symbolichotkeys.plist, 2) shut down (not sleep, shut DOWN) your Mac, 3) zap your PRAM AND reset your SMC (support.apple.com/en-us/HT201295), then... 4) restart your Mac. I have been successful with getting this fix to "hold", even between reboots. I'd like to see how other fare with this direction. – jschrab Jan 25 '16 at 23:21
0

Mouse Selection and Action Assignment

You will notice that as you choose different options from the "Assigned action" column in the dropdown menu that the options in the bottom half of the screen will also change to correspond with the Action you selected from the menu. This is slightly confusing at first, but makes almost immediate sense once you realize what is happening.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .