5

After upgrading to Yosemite, I see just noise on the external monitor, using a MDP to HDMI converter and an HDMI to DVI cable. It worked very well on Mavericks. I have no display now after updating, it just shows grey noise. Tried resetting SMC & PRAM. Additionally, I have tested each of the cables individually and they are okay, so it has to be a software problem.

Display screenshot:

This is what my display looks like

It shows flickers in red color sometimes.

Macbook gives display on another setup, but flickers a lot. (my friend's) its a MDP to VGA adapter plugged to VGA monitor.

Mine gives no display, I'm disappointed. Need help please.

  • Does it show up in Display profiles in About this Mac and in ColorSync Utility app? – Ruskes Oct 27 '14 at 19:50
  • You're not alone. discussions.apple.com/message/26885684 – Scott Lahteine Oct 28 '14 at 9:16
  • yes it does show up everywhere – Syed Usman Nov 8 '14 at 12:09
  • I have this same problem and have yet to find a solution. MBAir 11" 2014, with Mavericks the external monitor via Thunderbolt to DVI worked fine, after upgrading to Yosemite I get the same thing as Usman... My monitor works fine if connected on startup, but after sleep, or disconnect/reconnect, it goest to this noise display... annoying! – MOK9 Jan 15 '15 at 10:42
  • 1
    Plugging the cable out and in again fixes it for me, but that can't be a permanent solution – Niall Apr 8 '15 at 11:55
1

UPDATE

I almost forgot I had this issue, recently I changed cables. I am now using MDP to HDMI without adapters. Before I am using DVI to DVI Cable + DVI to MDP Adapter.

I think you need to avoid 2 conversions and use only 1 cable.

OLD ANSWER

It is also happening to me, and I can't find the solutions either. But I figured out how to avoid it.

When booting up mac

  • turn off monitor first and then power on the mac.
  • turn on the monitor after the mac finished boot or in the login screen

Settings

  • Open system Preferences > Energy Saver
  • Click Power Adapter tab(assuming your mac is plugged in) and slide the 'Turn display off after' to at least 1 hr.

It also occurs when mac goes to sleep and to avoid it, the steps above should be followed. Only do the settings step if you don't mind the power consumption.

Please let me know if you have better suggestions but this works for me as of now.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .