0

I formatted a 1TB Seagate USB 3.0 hard drive as ExFat to be used on both a MacBook and a Windows PC. The formatting was done on Windows and there isn't any issue when I access it through Windows. I have tried the hard drive on 2 MacBooks so far and it doesn't come up on either one of them when I plug it in. The MacBooks are running OS X 10.7.5.

I was under the impression that OS X was capable of operating with exFat. You'll have to excuse my ignorance to this as I mainly work with Windows or Linux.

Any help would be appreciated and if there is a work around to this problem it would be much appreciated.

1
  • I'm having the same problem and my IT ppl have informed me that the only solution is to reformat the drive on a Mac. Is there any other option?
    – Lindsey
    Commented May 2, 2017 at 12:00

2 Answers 2

2

I haven't tried this myself as I haven't had this similar problem, but I read that it is the cluster size that you select during formatting which is the issue. If you plan to use with Mac, format the drive using a cluster size not more than 1024. The problems I have are kind of different with exFat and mostly when the drive is not ejected properly under mac, everytime this happens i have to do a verify/recover step which takes quite a lot of time as mine is also a 1TB drive.

0

I have done this myself with no issues whatsoever, however my only difference is I formatted the drives using Mac, now this might be speculation and I don't Know how much time you have but if you're able to reformat the drive using Mac

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .