2

I have an iPhone 5 which I purchased (from India) in Nov 2012 and now it is out of warranty. I found an old SIM Card, which I purchased from Singapore when I was visiting that country, and put it inside my phone just to check if it still works or not.

I asked my friends to call me on that number, they could hear the phone ringing tone but my phone was not ringing so after that I switched back to my local SIM which was working before. Now I am unable to make any calls from my number, all outgoing calls fail immediately with a "Call Failed" message and I can hear 2 beeps. I can receive Incoming calls, send and receive texts and can browse the internet using 3G data connection on the same SIM.

I tried the my local SIM in other phone and it works perfectly fine which confirms that there's no issue with the service provider. I Tried some other local SIM in my iPhone 5, that doesn't work either.

This is definitely some issue with my iPhone 5. What could the issue be? I am really worried because it is out of warranty now.

  • 1
    I saw a similar problem here but doesn't seem to help :( – Anuj Rajput Oct 27 '14 at 11:16
1

Another solution I found to this problem:

Open Settings -> Phone -> Show Caller ID

It'll take some seconds to load the and show a loading indicator, after that is done the phone will be able to make and receive calls

1

I found that the problem for call failed on my iPhone 6 was the bad date & time settings. My location-based timezone was not enabled, and the phone time was incorrect. I disabled the auto time & date, reinserted the sim card and BOOM!

I got the dots. It works.

Source: http://www.unlockboot.com/2015/10/fix-call-failed-iphone-6-plus-6-6s-6s.html

  • is any of them a permanent fix? The caller ID and *#31# are temporary fixes, the phone restarts and it again does the same behaviour – Anuj Rajput Nov 6 '15 at 4:29
0

I tried

Settings -> General -> Date & Time -> Set Automatically Turn it OFF

I set the Time Zone manually to the local time zone and set the time back to when I bout the phone in November 2012. After that I just changed the time to the current time.

After that I found out the Location Privacy Setting for updating the time zone was disabled in the Settings -> Privacy -> Location Services -> System Services -> Setting Time Zone. This must have happened when I switched my SIM Card. I turned it on and now IT'S WORKING :D

You must log in to answer this question.

protected by Community Feb 11 '15 at 17:08

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .