38

Note: The only thing that changed in my setup is installing Yosemite.

Since installing Yosemite, I'm having a somewhat peculiar problem: WiFi works fine, and BT works fine. But WiFi + BT working together at the same time is a different story.

I first noticed this yesterday. Two things happen, and the second is more prevalent:

  1. I was using Apple's Magic Mouse + wireless keyboard, and began downloading a large file. Once this happened, mouse movement began being really slow, as if I'm trying to move the mouse on a very uneven surface. Pausing the download would bring the mouse's movement back to normal.

  2. But then something else started happening: Turning BT on would effectively kill my internet connection. From the moment I turn on BT and start using mouse & keyboard, my download speed would go quickly from 1.3MB/s to 500B/s (yes, Bytes), and die slowly from there. When this happens, my mouse movement is just fine. Upon turning BT off, download speed shoots back up to 1.3MB/s.

So to me it seems like BT and WiFi are "competing" with each other, like they're sharing the "same lane" when they shouldn't. Either the normal WiFi speeds will make my mouse move really slowly, or, if my BT is working fine, then my WiFi download speeds will be abysmal. This seems to only happen (or be noticeable) when I'm downloading something like a big file.

I've tried many solutions — PRAM, hardware tests, etc..nothing seems to have helped.

WTH?

Note: This question isn't about the (seemingly more common) WiFi dropping issues, please don't hijack it.

Update 1: There seem to be more people having this issue.

Update 2: Problem persists even after updating to OS X 10.10.1.

Update 3: Over 5 months later, and Apple still haven't fixed this.

Update 4: (29/10/15) One year later (on the latest OS X El Capitan), and my rMBP is still suffering from this issue. Work perfectly on their own, but together they get very challenging. For those who suggested to just get a 5GHz router — I appreciate your responses. However, I don't think I should be obligated to buy a new router just because Apple messed up their software. This is no fix for the underlying issue that is clearly still there for many people. The answer selected as "correct" was auto selected since this was a bounty quesiton.

  • 1
    I'm experiencing the same problem on my late-2013 MacBook Pro. I've been using a bluetooth keyboard/trackpad for a year with no issues, but after installing Yosemite my Wi-Fi performance is poor in general and my laptop will lose its connection to the Wi-Fi network entirely several times an hour. I have to turn Wi-Fi off and back on in order to reconnect my laptop to the network. – Patrick Oct 27 '14 at 15:25
  • @Patrick I have a similar setup (Wifi + Bluetooth Mouse) and a similar issue: apple.stackexchange.com/questions/155799/… – ohho Nov 12 '14 at 1:32
  • What happens if you change the wifi channel or frequency. I thing BT may be 2.4.. – markhunte Dec 17 '14 at 18:59
  • I notice you mentioned PRAM, but did you try the SMC reset? This fixed a bluetooth lag issue for me a few weeks ago: support.apple.com/en-us/HT201295 – Mikey T.K. Dec 17 '14 at 21:20
  • SMC is the only fixed published by apple – Jake Stewart Dec 17 '14 at 21:48
23
+100

Bluetooth and IEEE 802.11/b/g/n (WIFI) use almost the same frequency bands:

  • Bluetooth: 2.402 - 2.480 GHz (79 channels)
  • WIFI 2.4 GHz (IEEE 802.11/b/g/n): 2.4 – 2.4835 GHz (11, 13 or 14 channels depending on the country)

Usually Bluetooth uses frequency hopping and changes the possible 79 x 1 MHz bands 1600 times a second to avoid disturbances while WIFI uses fixed channels.

Obviously something went wrong developing the latest Bluetooth- or WIFI-drivers.

The only workaround until Apple gets their drivers fixed is using dual band wireless access points. Those devices use two different frequency bands: 2.4 – 2.4835 GHz and 5.18 - 5.825 GHz (with some gaps). Connecting to WIFI 5 GHz (IEEE 802.11a/h/n) will not interfere with Bluetooth.

Almost all Macs sold since 2006 support 802.11 a/b/g/n.

Apple's answer: Wi-Fi and Bluetooth: Potential sources of wireless interference

BTW: Not only typical RF-based devices (like wireless phones, etc) but also bad-shielded USB3-devices and cables interfere with WIFI (2.4 GHz) and Bluetooth.

  • Very useful, I had internet sharing switched on, on my macbook and my bluetooth mouse stopped working. I just changed the shared wifi settings from channel 11 to channel 40 and everything works again. Thanks :) – chrismacp Nov 27 '18 at 19:12
6

Most likely the introduction of Continuity in Yosemite increases the demand for wireless bandwidth and that impinges upon the already crowded 2.4GHz band shared between Bluetooth and Wi-Fi. Many pieces of evidence support this theory:

  1. Bluetooth and Wi-Fi interference only came to the fore after the introduction of Yosemite so it can't be just due to the fact that they share the same frequency band (otherwise Mavericks would suffer from the same problem on a wide scale).

  2. The more Bluetooth devices that one has the more likely that one's Wi-Fi connection would deteriorate or even get dropped completely.

  3. The presence of any Bluetooth device that requires a large bandwidth and constant connection, e.g. Bluetooth speakers, almost always incurs interference.

  4. Removing Bluetooth PAN from one's network or terminating AirDrop service work for some (most likely those with very few Bluetooth devices) albeit for a short period of time suggests that congestion is a culprit.

  5. Finally, those who use routers with dual-band support, e.g. one from the latest AirPort lineup, don't seem to suffer from this problem.

I also suspect that people who suffer from this type of interference the most are those who have devices that can only support up to 802.11b/g on their network, e.g. a pre-2009 PC or Mac.

Despite the instability of discoveryd, Apple kept it for three updates before finally removing it on the fourth. Apple must've felt the need for a new network service that can both accommodate the augmented bandwidth requirement of Continuity and the security demand that it wants to meet.

Update: Restricting my Airport Express (1st gen) to 5 GHz has made the problem go away completely and my Wi-Fi speed has jumped an incredible three-fold.

  • 1
    Nice analysis! 802.11b and Bluetooth have always used the same bandwidth (2.4 GHz, since their inception). ---- They are condemned to collide. They can't coexist pacifically, no way. – dan Feb 8 '16 at 7:36
2

IMO - the true fix for this is to get your WiFi network off 2.4 GHz when it's not reliable.

I put together a bit of a guide on how to know if you have to spend the $$ to get a better frequency, and the tools/books are about $20 each.

  1. Get off 2.4 GHz - use 5 GHz as it's far less susceptible to interferance and channel overlap.
  2. If you are on 2.4 - get a tool like WiFi Explorer to make sure you have a viable environment to have a reliable experience.
  3. If you want to learn more and have limited time to piece things together from internet volunteers, this take control book by Glenn Fleishman is excellent.

See Yosemite keeps dropping WiFI connectivity for more details on how to diagnose an interference issue between BT and WiFi on 2.4 GHz

  • 1
    I can confirm that the WiFi issue (drop from 50Mb/s to 2Mb/s as soon as I would turn magic mouse or keyboard on) completely disapeared as soon as I reconfigured my WiFi router from 2.4 GHz to 5 GHz (by simply choosing 5GHz in a dropdown list and confirming with Apply - nothing fancy is needed if your router supports that frequency). – Marko Bonaci Dec 3 '15 at 15:13
1

While still not perfect, removing the Bluetooth PAN device (even if its not connected at all) from the network devices helped me greatly.

  • Link seems to be broken. Can you update the answer with a link which works and maybe summarize the steps required directly in your answer? – nohillside Dec 1 '16 at 7:05
  • I removed the link. There was a device in network settings named like that. – MarZab Dec 1 '16 at 7:13
0

For visitor who are using BootCamp and encounter this question while searching for a solution, this worked for me on MBP 2017 with Microsoft Designer Set (Mouse and Keyboard)

Device Manager > Network Adapters > Broadcom 802.11ac Network Adapter > Right click and Select Properties > Advanced Tab > Bluetooth Collaboration > Disable

  • Your instructions seem to be for Windows, but the question is regarding MacOS. – PoisonNinja Jun 5 '18 at 16:47
  • @PoisonNinja I answered here because while you are searching for a solution for your Bluetooth Keyboard and Mouse (Using BootCamp on Mac) you encounter this question. So, I have answered here for the benefit of future visitors. The problem is same because the machine is same. – M Fouad Kajj Jun 5 '18 at 18:12
  • Thanks for the edit. I'm surprised that the issue also appears on Windows however, as the accepted answer seems to indicate that this is a MacOS driver issue. – PoisonNinja Jun 5 '18 at 20:29
  • Thank you. Life Saver! Fixed BT mouse lag that way. Had to rollback Bootcamp driver for Broadcom 802.11.ac to 7.35.118.49 to get Bluetooth Collaboration setting there. – Evgenyt Oct 25 '18 at 12:17
  • @Evgenyt Happy to hear that :) – M Fouad Kajj Oct 26 '18 at 6:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .