4

I am using 2 displays on my Mac Mini (late 2013), and have 6 desktops on each of the displays.

  • Primary display: 6 desktops
  • Secondary display: 6 desktops

However, after upgrading to Yosemite, it adds 1 more desktop and moves all additional ones to the primary monitor on startup:

  • Primary display: 13 desktops
  • Secondary display: 1 desktop

This was working properly on Mavericks. I can do it manually, but don't want to do it every single time I boot the computer.

I couldn't find any related options in "Preferences -> Displays".

Any ideas how can I fix this?

5

I am having the same issue and I believe it's a system bug (10.10.1) without any good workarounds. Even if you have no extra spaces on your secondary display, an extra space will show up on your main display on every reboot.

I will summarize for you the various approaches I've tried and the results of each. Only the first one solved it totally for me, but it's not ideal as you have to get used to making your secondary display into the new primary display.

(My two displays are different sizes which limits the ways it can be solved.)

  1. If your secondary display is being seen by your Mac as "primary" (does the boot screen Apple logo first appear here?), then you can use Display preferences, under Arrangement, to move the menubar to your secondary display. I tried it and it fixes the issue, but now everything defaults to the secondary display. You will constantly see new notifications, new windows, etc. popping up on the secondary display. Not ideal but it solved the issue of spaces being pushed over to the main display after every reboot.

  2. If your secondary display is being seen by your Mac as "primary" (does the boot screen Apple logo first appear here?), then maybe you can swap the ports where these displays are plugged in. I purchased the adapters in order to do this, but it was a total failure for me. No matter where I plugged in my smaller display, the Mac picked this for the boot screen every time. I even trashed all display preferences and zapped the PRAM to start fresh... no matter what I tried, the smaller secondary display booted as the primary. Unless you've set the menubar on this same display in preferences, the bug you're reporting will remain.

  3. On the Apple forum, several users have reported that turning off auto-login solved it entirely. This trick also failed for me. The boot process looked nicer as you no longer had to look at desktop pictures shifting around and re-sizing, but after logging in, the root problem of spaces shifting over to one display remained.

  4. Turn off the "displays have separate spaces" item in the Mission Control preferences. Not a practical solution. This is like killing the patient to cure the disease. Clearly there is a bug when using separate spaces that urgently needs to be addressed.

  5. If your two displays are the same size and you don't care which one is primary, then whichever display contains the Apple logo on boot will become your primary display. Use Display preferences, under Arrangement, to move the menubar to your this display. Then physically arrange them on your actual computer desk to your liking. This is the only perfect solution, but obviously works only when you don't care which physical display is set as the primary.


EDIT:

Since posting this answer, I submitted this bug to Apple using my Apple developer account on December 18, 2014. The current status of my bug report (19299246) is "open". I will update this answer as I track the bug with Apple.

  • Thanks a lot for your response! I am still having exactly the same issue, so I will try using your fixes and see if that will help. Will keep you posted. – Aram Boyajyan Dec 13 '14 at 12:21
  • Unfortunately, it's the same after a reboot :( – Aram Boyajyan Dec 16 '14 at 9:05
  • @Ivanhoe123, that's what I experienced on most of my attempts. It's a system bug and there may not be any good workaround. Just to be clear, my 5 suggestions are completely independent of each other and not meant to be used at the same time. Suggestion 1 & 2 would cancel each other out, for example. – Sparky Dec 16 '14 at 15:48
  • Thanks for the clarification; I did try the fixes separately. I still hope that this will be addressed in some of the next system updates though. – Aram Boyajyan Dec 17 '14 at 10:18
1

Open displays in Sys Pref. Drag JUST THE MENU BAR icon in the top of the primary display from one display to the other. Leave the displays as they are otherwise. Poof. Done.

  • Thanks for the answer, but this didn't work for me. It's the same after I rebooted the computer. – Aram Boyajyan Dec 16 '14 at 9:04
0

I had the same problem and I solved it the following way: In settings->mission control, you'll find an option called "displays have separate spaces". That was ticked bt default and when I unticked it (*) I at least had multiple spaces on my secondary screen. Maybe not the solution you were looking for, but for me multiple desktops on my secondary screen is pivotal, and now I can work again

(*)Note that it requires that you log out and then in again.

  • 1
    Thanks for sharing! This unfortunately doesn't solve the issue for me and others who need independent multiple screens. – Aram Boyajyan Nov 4 '14 at 8:56
0

Sparky's suggestion #2, swapping the ports that the displays connect to, resolved this problem for me.

I'm using a 2013 Mac Pro 6,1 with two displays plugged into the bottom pair of Thunderbolt ports that share the same bus. No matter what else I change the monitor that's plugged into the port on the right – nearest the power button – becomes the primary monitor.

You must log in to answer this question.

protected by Community Jan 27 '15 at 20:02

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .