I recently downloaded Yosemite, and I'm trying to update my Xcode. I hit 'Update' in the App Store, and but it's been stuck at 'Waiting' for the past 30 minutes.

As seen in Launchpad

As seen in the App Store

What can I do to fix this?


8 Answers 8


Yeah, a lot of people have been facing this issue. First, cancel your update. (In the AppStore update window hold Option to show the Cancel button.)

Now, you can do two things:

  1. Download and install the Xcode DMG from here (if you have an Apple Developer Account)

  2. Or try clearing your cache, and restart the download from the app store. You can use third-party apps or enter this command in your terminal:

    rm -rf "$(getconf DARWIN_USER_CACHE_DIR)/com.apple.appstore"

  • After downloading the DMG Xcode can take a long time to startup because it Gatekeeper seems to check the application for a while, thats what happend to me. source: iphonedev.tv/blog/2014/9/8/…
    – elhombre
    Jan 23, 2015 at 10:36
  • 5
    I keep forgetting that you need the <kbd>Option</kbd> to show very useful tools. All I needed to do in my case was cancel the installation and restart it. Feb 12, 2015 at 13:12
  • @elhombre - thanks for the warning - getting xcode 7.2 re-installed took hours (literally) using the .dmg - to download and then install. And then there is the need to reinstall plugins, new documentation etc. Not a great user / developer experience when compared with say JetBrains IDE products whose upgrades are generally seamless.
    – arcseldon
    Dec 11, 2015 at 4:35
  • 4
    I'd also recommend using the commandline softwareupdate tool instead of using the app store. softwareupdate --install --all --verbose
    – onlynone
    Jan 21, 2016 at 15:14
  • 2
    @onlynone Command line did not work to install Xcode. :(
    – Otávio
    Feb 3, 2016 at 21:16

Just wait it out. If you attempted a fix listed in another answer here, quit all applications, restart your computer, and when you boot back up, open the app store to the update page, click the update button and forget about it. It took mine about 20 minutes to actually start and move out of "waiting". I read reports that for some people it took about an hour for it to start.

I tried everything else before and was ready to do a full reinstall of xcode. Nothing worked but for me to just wait.

  • 2
    Just wanted to chime in and say this is what "worked" for me. I guess the correct answer here in one word is "patience."
    – CoBrA2168
    May 4, 2016 at 11:12
  • 1
    If this is the solution (I am still waiting to see), then the lack of any indication of progress is part of the problem.
    – sdenham
    Nov 2, 2017 at 11:51
  • 2
    Pro tip if you are impatient and want to see the progress: Open the "Console" application and filter messages for Xcode, a lot of log events regarding the update are written there. Nov 10, 2017 at 10:24
  • waiting it out worked for me. First I signed out of my app store account, then I restarted the mac, then I signed back in after selecting "update". Waited about 5 minutes and then it changed from "waiting" to "installing"
    – Lucky Mike
    Apr 5, 2018 at 19:23
  • @sdenham - actually, it isn't making any progress while "Waiting..." is showing. If it was making progress, it would be showing a download progress bar. Whatever it is waiting for, is not happening. For some people, never happens. So one could say that the problem is there is no way for an expert user to ask what it is waiting for - which might help us decide what to do about it. Sep 7, 2018 at 21:17

I solved the problem by moving Xcode from my Applications folder to the trash bin. I didn't have an option to cancel the update (all the buttons under Update in the App Store were grayed out for me).

Once I typed in my password to confirm the move, the App Store prompted me to either cancel the update, or delete the app. Opting to delete the app caused the update to start downloading immediately.

  • 1
    This seems like the most simple solution, and worked for me having tried a bunch of fancier ways. Mar 31, 2016 at 17:22

This simple approach worked for me:
I did not cancel anything, open AppStore and initiate the update (if you haven't done it yet); then click on the "Store" in the top-left menu and choose the following option - "Check for Unfinished Downloads...". Enter your Apple ID and password and you everything will be up and running.

The reason is that XCode does require additional confirmation before download.

Hope that helps.

  • 3
    This did not work for me. It may work for others, so I didn't downvote.
    – rinogo
    Sep 6, 2016 at 15:50
  • I don't see a "Check for Unfinished Downloads" anywhere (Catalina, 10.15.5) Jul 19, 2020 at 10:28

Just to add another answer here, I had two versions of Xcode in the launchpad. Opening one brought up a dialogue box asking if I would like to "Install additional components", which seems to have fixed it.

Apart from the two copies of Xcode. And now that Xcode is running, the "upgrade" is downloading. See what happens....


Yesterday this happened to me during regular check for updates, and between multiple restarts, and removing manifest.plist things started working again.

rm "$(getconf DARWIN_USER_CACHE_DIR)/com.apple.appstore/manifest.plist"

( I actually did some renaming to discover that this was the file of interest.

  • I think what this answer is adding to the accepted answer, is that the specific file within com.apple.appstore that is relevant is "manifest.plist". Sep 7, 2018 at 21:02

There could be multiple reasons for this happening, will explain my scenario.

Problem (Xcode-Beta):

  • I had Xcode and Xcode-beta installed, I deleted Xcode-beta before tapping on Update on the App Store
  • Xcode was waiting to install for over 10 min, restart of the Mac didn't help.


  • Go to Launchpad and noticed a completely separate app (without an app icon) waiting to install. On the Launchpad, press and hold till the icons wiggle, delete the app that didn't have an icon.
  • Go to AppStore and try installing

I understand that this was a specific case, just stating in case somebody faced a similar issue.


This worked perfectly for another App Store download stuck in "waiting". I quit the App Store, opened Terminal, pasted in code from Sheharyar's post above to clear cache, and pressed Enter. Restarted App Store and was able to begin my download immediately.

  • 2
    Welcome to Ask Different! This doesn't appear to be a standalone answer, and would probably be better as a comment on the previous answer. I know you don't have the points yet to comment, but I've asked someone to come and look at moving it. In the mean time you can see if you can get the points required to comment! Try browsing and see if there are any questions you want to answer or ask.
    – JMY1000
    Jul 7, 2016 at 17:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .