6

I have a combination of Win7 - XP & Apple macbook machines, running on my windows network.

The macbook up and till recently had Mavericks 10.9.5 OS X ,, a few days ago I upgraded the macbook to OS X Yosemite.

With upgrades you do get the odd thing going wrong but I have managed t resolve all but one problem in that I can no longer see any of the macbook-shared folders within the XP network icon.

I can see them and login to them via the Win 7 machines network icon, but I can not see any of the mac folders ( or drive ) within XP …

I therefore have to do the following :-

Start - Run

Then type the path to the macbook folder .. a login prompt and password appears but when I put in the user and password ,, the login re-appears but first with my XP machine user name back slash and the macbook user with password .. reappearing again and again after trying to login.
The error was logon failure: unknown username or password

I can though WinSCP from my XP to the macbook using the same login credentials

But I just can not get past this XP to macbook network access – I can however login from the macbook to the XP machines network drives and folders.

Does anybody have any solutions to this as I have come up stuck here

  • If you change your username to your-mac's-name then a backslash then your-username does it work? – tubedogg Oct 26 '14 at 4:06
  • @tubedogg I just tried that but it did not work ( thanks for the suggestion ) – user380226 Oct 26 '14 at 9:58
  • @user380226 This site does not work like your usual forum site, so discussions (if required) should take place in Chat or (if they are short) in comments. You can always comment on your own posts (assuming you are logged in). Please see the FAQ to understand how the site works. – nohillside Oct 26 '14 at 10:25
5

I had a similar issue and this post solved it for me:

https://discussions.apple.com/message/26964292#26964292

It may be the same discussion that Tetsujin references, but the setting to use is NOT "Send LM & NTLM - use NTLMv2 session security if negotiated" -- you should use "Send NTLMv2 response only". After I made that change, I connected to the share, put in my Mac username & pwd, and it connected.

  • This single configuration change fixed my authentication problems from a Mac OS X 10.10 Yosemite client to Windows 7 Service Pack 1 SMB shares. Thanks! – Joel Purra Feb 2 '15 at 13:02
  • 2
    After 2 weeks of suffering this precise issue myself, Google found my old answer - but actually, yours was the correct one. Fixed in 30 seconds. I'm going to tweak my answer to be a) more correct & b) add the search line I used to eventually find it. – Tetsujin Mar 24 '15 at 11:46
3

The Windows machine generates this error -
logon failure: unknown username or password OS X
& re-presents the login page. No amount of credential-checking/switching seems to work.

It appears that there is a Console error generated on the Mac at the same time as the Windows machine tries to connect -
od failed with 2 proto=ntlmv1-with-v2-session

Things to try...

  • (a) turn samba off and on again in sharing…

    System Prefs > Sharing > File Sharing > Options…

    enter image description here


  • (b) change the local security policy on your PC.

    1. Click Start
    2. Click Control Panel
    3. Click System and Maintenance
    4. Click Administrative Tools
    5. Double-Click Local Security Policy
    6. In the left pane, click the triangle next to Local Policy
    7. In the left pane, click Security Options
    8. In the right pane near the bottom, double-click "Network security: LAN manager authentication level"

    Then try one or both of these options. The 2nd worked for me.

    1. Click the drop-down box, and try either
      "Send LM & NTLM - use NTLMv2 session security if negotiated" or
      "Send NTLMv2 response only"
    2. Click OK

Sources:
https://discussions.apple.com/thread/6613032
http://www.jimmah.com/vista/net/ntlm.aspx

  • THANK YOU!!! The second option (NTLMv2 only) also worked for me. – Jamie Kitson Jul 13 '16 at 9:31
  • This allowed me to connect from a YOSEMITE mac to the same windows 7 pc. But a SIERRA mac is still unable to connect. – frumbert Jul 16 '17 at 0:17
1

I have exactly the same error you described and have been trying to fix sharing files between Windows XP and Mac Yosemite for a week. I will share my findings with you hoping we might find the answer.

Error Message:
This is what appears in the Mac's console every time a Windows XP machine tries to access it. It then asks for the password again and again showing the same error.

 digest-request: init request
 digest-request: init return domain: [Mac] server: [Mac] indomain was: <NULL>
 digest-request: uid=0
 digest-request: od failed with 2 proto=ntlmv1-with-v2-session
 digest-request: user=[Mac]\[User]
 digest-request: kdc failed with 36150275 proto=unknown
 digest-request: guest failed with -1561745590 proto=ntlmv1-with-v2-session

Probable Cause:
When Apple released Mac OSX 10.10 Yosemite it changed the default file sharing protocol to SMB3 but they say that they still support AFP, SMB2 and SMB1 (Windows XP only uses SMB1). In order to have done this they must have fixed their previous buggy implementation of SMB and therefore must have changed lots of code, probably messing up the Windows XP file sharing in the process.

Things I Have Tried:
You may try them as well and see if you get a different result.

  • Turning sharing On and Off from the Mac
  • Creating a new Administrator User and Sharing Only User
  • Repairing permissions with Disk Utility
  • Turning off all firewalls (Windows and Mac)
  • Activating Windows File Sharing in Sharing Options
  • Deactivating AFP File Sharing in Sharing Options
  • Changing the Local Security Policy to "Send LM & NTLM - use NTLMv2 session security if negotiated"
  • Connecting using IP address
  • Changing the Mac's NetBIOS Name
  • Setting the Mac's WINS Workgroup Name in Network Settings

Things I Have Not Tried:
I really do not want to do this but will have to if I don't find any other solution.

I hope this helps you and that we can find a solution for the problem. Please let me know if you make any progress.

  • 1
    try the other option for local policy - "Send NTLMv2 response only" That fixed my month-old issue. – Tetsujin Mar 27 '15 at 11:05

You must log in to answer this question.

protected by Community Oct 26 '14 at 10:23

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .