8

I've upgraded my OS X to the latest Yosemite GM Candidate and cannot for the life of me figure out how to partition my SSD for BootCamp. Here are some screenshots of the problem:

enter image description here

And when i try to partition from Disk Utility:

enter image description here

What is the problem and can it be solved? I read somewhere something about needing to wipe my hard drive and start over with a fresh OS X install, but i really would prefer not to do that, any help is appreciated. Thanks.

P.S: I've tried verifying disk permissions, and repairing in recovery mode. Nothing worked.

MacBook Pro with Retina display, OS X Yosemite (10.10)

diskutil list output

/dev/disk0
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *121.3 GB   disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:          Apple_CoreStorage                         120.5 GB   disk0s2
   3:                 Apple_Boot Recovery HD             650.0 MB   disk0s3
/dev/disk1
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                  Apple_HFS Macintosh HD           *120.1 GB   disk1
                                 Logical Volume on disk0s2
                                 D2BB45DB-C690-47B2-BFF0-E0A5D812EE6A
                                 Unencrypted
/dev/disk2
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:     FDisk_partition_scheme                        *8.2 GB     disk2
   1:                 DOS_FAT_32 WININSTALL              8.2 GB     disk2s1

diskutil cs list output

CoreStorage logical volume groups (1 found)
|
+-- Logical Volume Group 312C0A5B-AC3E-4008-895F-6EDFDD386825
    =========================================================
    Name:         Macintosh HD
    Status:       Online
    Size:         120473067520 B (120.5 GB)
    Free Space:   35721216 B (35.7 MB)
    |
    +-< Physical Volume 5292E607-3F97-46C0-8E92-97BC853367D5
    |   ----------------------------------------------------
    |   Index:    0
    |   Disk:     disk0s2
    |   Status:   Online
    |   Size:     120473067520 B (120.5 GB)
    |
    +-> Logical Volume Family 736C4179-B89A-4EBE-90C7-F0CE4705D2B3
        ----------------------------------------------------------
        Encryption Status:       Unlocked
        Encryption Type:         None
        Conversion Status:       NoConversion
        Conversion Direction:    -none-
        Has Encrypted Extents:   No
        Fully Secure:            No
        Passphrase Required:     No
        |
        +-> Logical Volume D2BB45DB-C690-47B2-BFF0-E0A5D812EE6A
            ---------------------------------------------------
            Disk:                  disk1
            Status:                Online
            Size (Total):          120101797888 B (120.1 GB)
            Conversion Progress:   -none-
            Revertible:            No
            LV Name:               Macintosh HD
            Volume Name:           Macintosh HD
            Content Hint:          Apple_HFS
  • please do a 'diskutil list' & 'diskutil cs list' with Terminal.app and add the output to your question. Yosemite GM or Release? – klanomath Oct 25 '14 at 17:57
  • @klanomath Yosemite GM, the latest Update provided by apple. I also tried this with the release, however same result. – ThatGuy343 Oct 25 '14 at 18:01
  • @klanomath I've added the diskutil command output to the question. – ThatGuy343 Oct 25 '14 at 18:01
  • disk2 is a thumb drive with Win7/8/8.1? – klanomath Oct 25 '14 at 18:16
  • Windows 7. It's 8GB and has the Bootcamp installed windows support software. Ready to boot from once i have a windows partition made. – ThatGuy343 Oct 25 '14 at 18:17
6

This Mac Book Retina was originally delivered with Mountain Lion. The upgrade history contains Mavericks, several Yosemite DPs and finally the Yosemite GM Candidate.

One of the Yosemite Developer Previews transformed the previous Apple_HFS partition into a Logical Volume Group.

The (only) Logical Volume is not revertible:

enter image description here

The Boot Camp assistant can't modify the partition map and shrink such a LVG to free up some unallocated space for a Windows installation on a hard disk.

The only possibility (we found) to solve the problem is a complete reinstall:

  1. Backup all your data
  2. Disconnect all external hard drives
  3. Restart into Internet Recovery Mode by pressing altcmdR
    (alternatively you may use a Mavericks or Mountain Lion Install Thumb Drive)
  4. start Terminal from the menubar/utilities
  5. enter following command at the Terminal prompt:

    diskutil cs list

  6. Copy the Logical Volume Group (LVG) alphanumeric UUID of your CoreStorage volume. The LVG UUID should be the first listed. In the above example the alphanumeric is:
    312C0A5B-AC3E-4008-895F-6EDFDD386825.
  7. Run the following command:

    diskutil cs delete UUID

    According to the number found above it would be:

    diskutil cs delete 312C0A5B-AC3E-4008-895F-6EDFDD386825

    This will delete your CoreStorage volume and your Recovery HD and reformat it as a simple HFS+ volume.

  8. Quit Terminal
  9. In the now opening window choose Disk Utility and format/partition/rename the internal drive. Choose 1 Partition, Mac OS Extended (Journaled) and GUID partition table (available with the option button). Quit Disk Utility.
  10. Now choose 'Reinstall Mac OS X'
  11. The originally shipped OS X will be downloaded and installed
  12. Set up your Mac
  13. Download and install Mavericks from the App Store
  14. Start Boot Camp Assistant, repartiton your Mac and install Windows
  15. Download and install Yosemite from the App Store

At step 10 one may boot alternatively to a Mavericks or Mountain Lion Install Thumb Drive if available and install the respective OS X.

Starting into Recovery Mode at step 3 doesn't help because it's impossible to delete the LGV then.

  • :) thank you again, this all worked perfectly and i now have 2 partitions (pc,mac). – ThatGuy343 Oct 27 '14 at 17:01
2

OP, you can run the following command "diskutil cs revert" in Terminal. It will non-destructively revert Yosemite's unnecessary CoreStorage volume setup into a "normal" (non-CoreStorage) setup. I had to run in on a few of the dev previews. You may have to run it as root.

  • 2
    I had a similar though not identical issue as the questioner. I could partition my drive in Disk Utility but Bootcamp could do nothing with it, not even remove the partition I created. This ultimately solved the issue I was having. – Robb Vandaveer Dec 13 '14 at 17:21
1

@klanomath answer is like killing a mosquito with a surface to air missile (SAM) that cost an arm and a leg.

The problem is simple: there is an error in your disk. I had the same issue, exactly. I will recommend you first check if there are errors on your disk, repair it and try Boot Camp once again.

How to Check for Errors and Repair your HD:

First, you have to shut down your Mac. Then, turn it on and immediately hold down Command + S to enter Single User Mode. Now, type in the following code into the command prompt interface:

/sbin/fsck -fy

Then, press Enter on your keyboard. That command checks and repairs inconsistencies in file systems that might prevent you from partitioning your drive. Once that has been completed, type in this code:

reboot

Hit Enter and your Mac will restart as usual.

Now, try running Boot Camp Assistant again to install Windows. You should not receive the previous error and will be able to run the installation without any hiccup.

Reference: http://www.hongkiat.com/blog/bootcamp-assistant-cannot-partition/

90% of the time, this will work. If it doesn't, you can then order for SAM from Lockheed Martin on Northrup Grumman by following the advice of @klanomath

0

You have file vault enabled on that partition, you cannot resize a core storage volume without first decrypting the drives contents. Goto System Preferences->Security & Privacy->Filevault, hit the lock icon on the bottom left and enter your login credentials, push the button labeled Turn Off File Vault, after confirming, you should see a progress bar showing the status of the drive decryption. Once the drive is completely decrypted you can resize the partitions.

This will completely decrypt your drives data, so once you are satisfied with your new partition setup and commit them to disk, go ahead and turn file vault back on. Also note the decryption process is not quick, it make take over a day. Hope this helps.

  • 2
    No, according to the asker file vault never was enabled: "Encryption Type: None" – klanomath Oct 26 '14 at 0:17
  • @klanomath You are correct, I incorrectly assumed from a quick glance at the partition scheme the op was using File Vault. Apparently Yosemite creates a core storage volume by default even though it may not be needed for anything. My answer is not relevant to the op's question. – Brian Duke Oct 26 '14 at 12:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .