2

I can't get the MacOS screenshot app to change the file format.
I've tried to change the settings with

$ rm  ~/Library/Preferences/com.apple.screencapture.plist
$ defaults write com.apple.screencapture type -string "png"
$ defaults write com.apple.screencapture location "/tmp/"

rebooted, just in case, but when trying to save a new screenshot, I still can only save it as a .TIFF-image.

Some additional info: This issue was present even before the update from Mavericks to Yosemite. killall SystemUIServer does not make any difference.

Interestingly:

$ defaults read com.apple.screencapture
{
    location = "/tmp/";
    type = png;
}

File permissions, numeric UID and GID:

$ ls -lacn  ~/Library/Preferences/com.apple.screencapture.plist
-rw------- 1 501 20 74 Okt 31 15:59 /Users/jottr/Library/Preferences/com.apple.screencapture.plist

also,

$ ls /Library/Preferences/com.apple.screencapture.plist
ls: cannot access /Library/Preferences/com.apple.screencapture.plist: No such file or directory

So there's nothing in /Library/Preferences/ that could override the settings in ~/Library/Preferences/.

OS X 10.10 (14A389)

$ echo $OSTYPE
darwin14.0.0

Screenshot App Version: 1.8 (117)

I checked the File Permissions with diskutil, no errors.

2

Are you using ⌘ Command+⇧ Shift+3 and ⌘ Command+⇧ Shift+4 instead of Grab.app? Grab produces a .tiff file, but the keyboard shortcuts will produce whatever is set in that defaults entry (by default, .png).

0

The defaults write com.apple.screencapture type -string "jpg" | "png" | "tif" | "pdf" | "gif" | "bmp" command does indeed work in Yosemite, and one does not need to execute killall SystemUIServer: the change takes effect immediately, and persists in preferences.

As for the location showing up in the defaults read result, perhaps you can get rid of this anomaly by deleting or renaming ~/Library/Preferences/com.apple.screencapture.plist and executing the defaults write command above to recreate the .plist file.

  • OK, I rmed ~/Library/Preferences/com.apple.screencapture.plist, reran above defaults write command. The file exists, defaults read returns type = png;. Issue remains. Killing SystemUIServer does make no differnce, nor does restarting the screenshot app itself. – jottr Oct 25 '14 at 18:28
  • You should execute this command to set the screen capture to your Desktop: defaults write com.apple.screencapture location -string "~/Desktop" – IconDaemon Oct 25 '14 at 18:33
  • You might also want to see if there is a com.apple.screencapture.plist file in /Library/Preferences at the root level of Macintosh HD. There usually isn't one there, but who knows. If there is one, delete it. – IconDaemon Oct 25 '14 at 18:36
  • I did, but that did not make a differnce as well. I wouldn't see how it could in any event though. – jottr Oct 25 '14 at 18:36
  • So the location = "/tmp/" is still returned by defaults read? – IconDaemon Oct 25 '14 at 18:37
0

defaults write com.apple.screencapture type -string "jpg" worked for me. No sudo, just my user account. In 10.10. Thanks.

0

Hm. I found that upgrading from 10.9 to 10.10 reverted my default (jpg) to tiff. Annoying, took me a week to figure out. Surprisingly I tried the well documented method as given by the people above, and it worked immediately - but only if prefixed by "sudo".

So go for this:

sudo defaults write com.apple.screencapture type jpg

And it worked for me, without restart or killing any process.

EDIT : some commented below that sudo makes no sense; you are right. Even without, I get it to write to prefs about jpg:

$ defaults read com.apple.screencapture <enter>
{
    type = jpg;
}
  • Thx for trying to help, but that did not help. It wouldn't really make sense if it would ;) – jottr Oct 27 '14 at 15:39
  • Strange; after so many days it works for me still. The annoying bit is that the cmd+ctrl+shift+4 command (screenshot region to clipboard) still uses .tiff although the cmd+shift+4 (screenshot region to file) works with jpg. As a result, my copy-pasted regions to Mail are .tiff and unreadable by many clients. Bummer – thanosa75 Nov 14 '14 at 21:50
0

Strange; after so many days it works for me still. The annoying bit is that the cmd+ctrl+shift+4 command (screenshot region to clipboard) still uses .tiff although the cmd+shift+4 (screenshot region to file) works with jpg. As a result, my copy-pasted regions to Mail are .tiff and unreadable by many clients. Bummer – thanosa75 Nov 14 '14 at 21:50

I had the same issue and figured out that if you use .png instead of .jpg the copy-paste screenshot to Mail will work. I used the app OnyX to change it... maybe it helps you guys, too.

It's a shame that Apple makes the OS always worse with any update... at least it seems like it...

  • I have the same problem, and I originally did change mine to .png – Steven Klein Apr 27 '17 at 13:50
  • Changing it to jpg, then back to png fixed it. – Steven Klein Apr 27 '17 at 13:58
0

If it's working for saved screenshots, but not clipboard screenshots, try changing it to some different format, then changing it back.

For example, mine was set to png, but it was only working for screenshots saved as files:

$ defaults read com.apple.screencapture type
png

I fixed it by changing it to jpg, then immediately changing it back to png:

$ defaults write com.apple.screencapture type jpg
$ defaults write com.apple.screencapture type png

Now both files and clipboard are .png

Thanks to volker's message above -- that gave me the idea to try this.

BTW, I didn't use sudo, and didn't kill SystemUIServer. Neither was necessary.

Disclaimer: This is true for me on Sierra 10.12.4. It should be true for everyone else, but I make no guarantee.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .