9

When I was running Mountain Lion I selected "Allow apps downloaded from: Anywhere" in Security & Privacy. I updated to Yosemite a few days ago. The update set that back to: "Mac App Store and identified developers". I want to run some software from elsewhere. When I select Security & Privacy and click the padlock icon, a pane comes up asking me to enter my password. Since I don't have a password I simply click "Unlock". The padlock unlocks for a few milliseconds and re-locks far too quickly for me to change the setting. I know that I don't need a password as that pane lets me click Authenticate during software installation from a .dmg

So what do I have to do to change Allow apps setting now?

9

You have a few options:

  • Temporarily set a password to change the setting.

or

  • Hold down Ctrl, click on the app, then click Open from the menu shown. This will allow you to temporarily bypass the checks.
  • Thanks Stan, but that looks like a workaround for a "feature". Hopefully something will eventually be done to correct this. Cheers Chris – CptDangerous Oct 25 '14 at 10:34
2

You will need to temporarily put a password on, then you can just take it off. I had to do that for Steam and it worked perfectly. I think this might be a bug and hopefully they're gonna fix it.

  • 1
    I am having the same issue. I tried the temp password and it did the trick. Truly it was annoying and I would be shocked if Apple doesn't fix this soon. – user112484 Feb 4 '15 at 19:20
  • 3
    I was running into the exact same problem today. I'd try to open an app, and it'd pop up the not trusted dialog. Opening the Security & Privacy settings then clicking "Open Anyway" did nothing. If I changed the setting to "Anywhere" it just reverted back to the original setting. I was unable to fix this using the GUI... I was able to fix it using a command line tool. Close your System Preferences, and open Terminal.app. To see the status of Gatekeeper, run spctl --status. To disable Gatekeeper, run sudo spctl --master-disable. To enable Gatekeeper, run sudo spctl --master-enable. – livingstaccato Feb 7 '15 at 7:51

You must log in to answer this question.

protected by Community Mar 9 '15 at 19:48

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .