3

Yesterday I upgrade my MBP to OSX 10.10 Yosemite, everything went well. But When I try to start Pycharm, it shows me this

enter image description here

It means "You need to install old Java SE 6 runtime to run Pycharm".

It seems I'm not the only one run into this problem
https://intellij-support.jetbrains.com/entries/27854363-IDE-doesn-t-start-after-updating-to-Mac-OS-Yosemite-or-Mavericks

There're some hacks from the link above, but I would like to find an "official way" to solve this. I'm also curious about the cause of this problem.

Thank you!

9

You can also solve it by doing the following:

Locate your Installed package (PyCharm or IntelliJ), right click, show package contents

Under contents, open up Info.plist

Locate the JVMOptions dictionary entry, and find the key titled "JVMVersion"

The default value for that key should be "1.6*". change it to "1.6+".

Save it, and re-launch the IDE again.

You should be able to use it without JDK 6 installed.

  • True, but Java1.6 has better font rendering on Mac. – laike9m Oct 25 '14 at 12:41
  • 1
    This worked for me! Thank you. I wanted it to work with Java 8 u25 and this did the trick! – Splaktar Oct 26 '14 at 6:02
  • 1
    @laike9m, this is perhaps true, but I doubt that there will be further updates for JDK6 on the mac, except for maybe security updates. – cudiaco Oct 26 '14 at 12:53
  • Normally, I'd favor using a newer Java implementation, but, in this case, Jetbrains recommends against this as it will change the file signature on the plist file, and that will prevent further updates to the application, they say. – Jemenake Dec 8 '14 at 2:21
  • Did not work for me, pycharm kept complaining. I went with the old jre 6 now. – binaryanomaly Dec 28 '14 at 10:27
2

OK, I found the official solution

Download Java for OS X 2014-001 from here, install, done :)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .