I sometimes need to mount USB drives that are NTFS formatted and write to them. On Mavericks I achieved this using the Homebrew formula ntfs-3g which depends on osxfuse.

After upgrading to Yosemite, osxfuse is broken. Homebrew message:

==> Upgrading osxfuse
osxfuse: OS X Mavericks or older is required for this package.
OS X Yosemite introduced a strict unsigned kext ban which breaks this package.
You should remove this package from your system and attempt to find upstream
binaries to use instead.
Error: An unsatisfied requirement failed this build.

I take this to mean that the kernel extension used by osxfuse is completely disallowed in Yosemite because it is not digitally signed by Apple, whereas in Mavericks it was allowed.

So, is there any way now to mount and write to an NTFS-formatted USB drive in Yosemite using either open-source software or free, unencumbered (not spyware/malware or bundled with useless toolbars etc.) software from the App Store?

  • Define "unencumbered"...all software from the Mac App Store has DRM.
    – tubedogg
    Commented Oct 24, 2014 at 5:46
  • User can disable OSX from checking for kext signature at at all. Trim Enabler doesn't have the Apple's blessing either, but its developer has the app enabled for Yosemite none the less. cindori.org/trim-enabler-and-yosemite Commented Oct 24, 2014 at 6:15
  • You have this soft paragon-software.com/home/ntfs-mac
    – StrawHara
    Commented Oct 24, 2014 at 6:15
  • Good question. I've been debating if the package really needs to be uninstalled, or if we should wait until it's upgraded. Like what fartheraway has said, it is possible to get around the kext signature issue, I supposed the question is if osxfuse (or contributors) will give it some attention.
    – vol7ron
    Commented Oct 26, 2014 at 22:29
  • The interesting thing is that ntfs-3g is still available via homebrew.
    – vol7ron
    Commented Oct 26, 2014 at 22:48

9 Answers 9


Open Terminal.

If you have brewed osxfuse installed, you have to uninstall it, because unsigned kexts are banned now. Type:

brew cask uninstall osxfuse

On the other hand, if you don't have Homebrew at all, download it:

ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"

Updating Homebrew is recommended.

brew update

If you don't have Homebrew Cask installed, type:

brew install caskroom/cask/brew-cask

Install a binary osxfuse package from Homebrew Cask:

brew cask install osxfuse

Install ntfs-3g:

brew install ntfs-3g

You need to create a symlink for mount_ntfs, in order to make drives mount automatically:

sudo mv /sbin/mount_ntfs /sbin/mount_ntfs.original 
sudo ln -s /usr/local/sbin/mount_ntfs /sbin/mount_ntfs

If you are running OS X 10.11 and the commands above fail, try:

sudo nvram boot-args="rootless=0"

edit: This doesn't work for me in the final El Capitan (from Mac App Store). I had to disable SIP through recovery. Could someone confirm that this is indeed necessary?

... and reboot your machine. Then try symlinking mount_ntfs again.

Thanks to bjorgvino.

  • 2
    Doesn't seem to work on 10.10.4. The device is visible in diskutil but is not mounted correctly.
    – tyteen4a03
    Commented Jun 13, 2015 at 20:08
  • 2
    mv: rename /sbin/mount_ntfs to /sbin/mount_ntfs.original: Operation not permitted
    – Cœur
    Commented Jun 28, 2015 at 15:24
  • 1
    @Cœur probably you forgot the command sudo. You need super user privileges for this action. Commented Jun 28, 2015 at 18:20
  • 1
    @agusgambina no, didn't forgot sudo. File or folder is locked. I'm on El Capitan.
    – Cœur
    Commented Jun 29, 2015 at 1:15
  • 4
    I'm on 10.11, I disabled SIP from recovery, then followed all the instructions. Whenever I plug in an NTFS drive, it does mount in /Volumes, and I'm able to use it, but strangely, whenever I unmount it, and plug it in again, it shows up as "<name> 2", "<name> 3" etc. depending on the number of times I unplug and plug it in again. The previous mounts still show up in /Volumes but I can't access them. This is a bit annoying. Any ides? Actually I can't even access it at all sometimes...
    – notadam
    Commented Oct 4, 2015 at 2:34

Quickly mount a NTFS disk read/write on all recent OS X (including Yosemite, El Capitan):

  1. Open Application -> Utilities -> Terminal
  2. Type mount and look for the line with your disk. It will show something like: /dev/disk3s1 on /Volumes/MyDisk (ntfs, local, noowners, nobrowse)
  3. Type the following in the Terminal, replacing /dev/diskXsX with your disk as shown in the mount command:

    sudo mkdir /Volumes/Mount  

    *Make sure that the device is not already mounted, if yes, please unmount it first. Otherwise it will result in error: mount_ntfs: /dev/diskNsN on /Volumes/Mount: Resource busy

    sudo umount /Volumes/<device_name>
    sudo mount -o rw,auto,nobrowse -t ntfs /dev/diskXsX /Volumes/Mount/
    open /Volumes/Mount/

To make this change permanent run the following (correct for El Capitan):

  1. Run the following command, changing /dev/diskXsX to your disk:

    export DEVICE=/dev/diskXsX   
    echo UUID=`diskutil info $DEVICE | grep UUID | awk '{print $3}'` none ntfs rw,auto,nobrowse 
    echo LABEL=NTFS none ntfs rw,auto,nobrowse
  2. Run sudo vifs and paste in the output from the previous 2 lines. To do this press down to go to the bottom of the file, A to start adding text, paste in the 2 lines then press escape and :wq to write the file. (vifs is the only safe way to edit the fstab in OS X).

  3. Run the following to mount the disk

    sudo umount /Volumes/$DEVICE 
    sudo diskutil mountDisk $DEVICE
    sudo open `mount | grep $DEVICE | awk '{print $3}'`

Note: The device will no longer automatically open a window when you attach it. To access it open a Finder window and select the Go -> Go to Folder to /Volumes

  • I think you might want to edit the answer to clarify what part people are supposed to change. Presumably, they should change just the Tpart to the volume name (yes?), not replace the entire DISK=T with the volume name.
    – D.W.
    Commented Apr 9, 2015 at 21:35
  • The awk with $5 does not work on my 0SX 10.10 (yields nothing). Command output formatting might have changed. I've used cut -b 30-80 as a workaround.
    – youri
    Commented May 25, 2015 at 14:24
  • 3
    Mine responds with "mount_ntfs: /dev/disk2s1 on /Volumes/Untitled: Read-only file system"
    – tofutim
    Commented Nov 22, 2015 at 1:08
  • 1
    I have the same error that @tofutim : $ sudo mount -o rw,auto,nobrowse -t ntfs /dev/disk4s1 /Volumes/Mount/ mount_ntfs: /dev/disk4s1 on /Volumes/Mount: Read-only file system
    – Maen
    Commented Jan 3, 2016 at 20:45
  • 1
    @tofutim and @Bigood -- The "read-only file system" message is often an indicator that the NTFS partition is "dirty" meaning that when it was last opened by Windows there was not a clean shutdown. Open the disk in Windows and run chkdsk d: /f where d: is the drive letter. Then make sure you do a clean shutdown or detach from Windows. Commented Jun 23, 2016 at 14:53

I normally use Paragon NTFS, but just tried this method with 10.10.1 and it seems to work after a rudimentary test [created a folder and copied few small files]

After disabling Paragon, a NTFS-formatted flash drive is not writeable: NTFS USB drive not writeable

I added that drive and the requisite flags to my fstab file: NTFS options in fstab

Then unmounted and reinserted the flash drive. Note that it no longer shows up in the sidebar under Devices. You have to navigate to the /Volumes directory to find it. However, it is now writeable. NTFS USB drive not writeable

No third-party software required, but you do have to repeat this for every target NTFS volume.

Additionally, there is script that can set up everything automatically: http://sourceforge.net/projects/native-ntfs-osx/files/?source=navbar (just succeeded with it on OSX 10.5.5 Yosemite).

  • Don't try this option. Atleast not for now. I lost my data because of this. Not once, but twice. First time, I was copying some file to hard disk and accidentally hard disk got ejected and to my surprise all data in that folder got lost. Second time, I was copying some file to hard disk and this time it wasn't ejected but still I lost my data :( Had to use recovery software to get back my data!!! If you are the one who concerns about your data, then better stay away from this option.
    – mac
    Commented Sep 26, 2015 at 18:18
  • 1
    In case your hard disk got corrupted, simply plug it in Windows. Then you will get windows popup saying "Recommend to scan" or "Continue without Scanning". Choose the first option. Select both check boxes in next screen (Fix Errors and Try repairing bad boot sectors). You will be able to recover corrupted folder :)
    – mac
    Commented Sep 27, 2015 at 10:31
  • This worked at first but it didn't work when I tried on the next day, so I ended up installing ntfs-3g. Commented Oct 20, 2015 at 14:28

Newer macOS

See newer answer at https://apple.stackexchange.com/a/213575/62697.

Older macOS

This answer is aimed at latest compatibility for OS X 10.11 El Capitan.

  1. Install latest osxfuse (3.x.x) from https://github.com/osxfuse/osxfuse/releases or from Homebrew with brew cask install osxfuse.

  2. Install latest NTFS-3G (2015.3.14) from Homebrew (http://brew.sh/).

As follow:

brew install ntfs-3g
  1. Link NTFS-3G to boot after temporary disabling System Integrity Protection.

As follow:

[reboot by holding CMD+R to get in recovery mode]
csrutil disable
[reboot normally]
sudo mv /sbin/mount_ntfs /sbin/mount_ntfs.original
sudo ln -s /usr/local/sbin/mount_ntfs /sbin/mount_ntfs
[reboot by holding CMD+R to get in recovery mode]
csrutil enable
[reboot normally]

The following guide worked on my Yosemite computer:

Macbreaker.com - How to Enable Writing to NTFS Hard Drives in OS X Including El Capitan

A guy called Niresh has simplified this process into a single installer:

Hackintosh Zone - Free NTFS Driver for Mac OS X (You will need to register on the website before you can download)

Installing this file; restarting the computer enables NTFS write.

  1. install FUSE with MacFuse compatibility layer,
  2. install NTFS-3G,
  3. install FUSE-wait
  • The second link has changed and requires registration. But the first link is fine. To summarize: (1) install FUSE with MacFuse compatibility layer, (2) install NTFS-3G, (3) install FUSE-wait.
    – Cœur
    Commented Jan 11, 2015 at 4:46

All recent OS X releases support NTFS natively (read/write)!

By default, the drive mounts, and you can browse the files. But it is read-only. To make the drive writeable, add the following line to /etc/fstab

LABEL=MyDrive none ntfs rw,auto,nobrowse

Replace MyDrive with the name of your volume (check the volume name in the Finder when you mount it).

Then unmount/remount it to see the changes. One convenient way to re-mount the drive is to use Disk Utility:

enter image description here

To see the drive after mounting it, look under /Volumes in Finder:

enter image description here enter image description here

This change is permanent.

To undo the writability when mounted on this machine, simply remove the entry for this drive from /etc/fstab.

  • 1
    Hmmm. Too bad Disk Utility won't format NTFS.
    – WGroleau
    Commented Nov 24, 2015 at 22:08

According to this thread, as a workaround, you can download and install the osxfuse binaries directly from the project instead of using homebrew:


But it sounds like this won't work if you have brew packages (such as Gluster) that rely on the osxfuse libraries, since they won't appear in your cellar.


The best cross platform format I use is vfat. Not ideal, but it works a charm and there's no mess no fuss :)

  • I do not know why this received a negative vote. It is, to some degree, a very valid point. Somebody might thing that NTFS is the de-facto file format and having NTFS-formatted flash drives causes issues on Mac. Therefore, for the casual user who just wants a flash drives that woks universally, exFat (tested OK) or vFat (not tested) helps solve the problem. In this scenario NTFS is not used at all.
    – Shailen
    Commented Jul 23, 2015 at 17:37

I always use Paragon NTFS. Just try it. You can do read/write from both sides and will forget this barrier for ever.

  • For curiosity, why minuses? What's wrong with the mentioned answer? Commented Jan 9, 2015 at 10:38
  • 2
    Maybe because the question was looking for something "free". Upgrading your OS and you start having to pay to read USB drives? That's unacceptable for many people.
    – Cœur
    Commented Jan 11, 2015 at 4:37

Not the answer you're looking for? Browse other questions tagged .