16

My sound does not work whe I try to turn up the volume it just show this

Speaker Muted

I tried looking on the forums but they didn't help.

Thank you for spending the time to answer, if you have any questions please comment them down below

  • Can you hold down your option key and click on the volume icon in your status bar? If you have an external monitor attached, you might need to select the internal speakers instead. Alternatively, you can go to System Preferences > Sound and select the speakers there. – Lingnik Oct 24 '14 at 3:30
  • @Lingnik in my external monitor it shows the name of my external monitor and as the type it shows HDMI, I click on it and it says: The selected device has no output controls – alex Oct 24 '14 at 15:22
  • What are your speakers attached to? Are they plugged into the headphone jack on your laptop, are they plugged into the monitor, or are the built into the monitor? Or do you not have external speakers -- and are expecting the sound to come out of the MacBook Pro's built-in speakers? – Lingnik Oct 24 '14 at 15:31
  • My headphones are attached to the headphone jack but aren't making any sound. I want the sound to come out of the macbook's speakers when the headphones are not pluggeed in and play inside the headphones when they are but right now I dont hear any sound what so ever. – alex Oct 24 '14 at 15:39
  • Got it, please see my answer below. I believe you need to switch from using the external monitor's "speakers" to the Internal Speakers. – Lingnik Oct 24 '14 at 15:41
16

By default, without an external monitor and no headphones plugged into the MacBook Pro, the audio should come out of the built-in speakers and you should be able to control the audio with the built-in keyboard volume controls. If you hold down the ⌥ Option key while clicking on the audio icon in your statusbar, you should see this:

audio-mbp-yosemite-nomonitor

If, however, you have an external monitor plugged in via Mini DisplayPort or HDMI, and your monitor supports audio passthrough, then you may be running into a problem of the MacBook Pro seeing that monitor as the primary audio output device.

If your goal is to play audio through the built-in speakers, simply select Internal Speakers in the drop-down shown above and you will be able to control the volume again. It should look like this screenshot:

audio-mbp-yosemite-monitors

If your goal is to play audio through the external speakers, and your volume controls do not work, then that means your external speakers (or monitor's speakers) do not support the volume controls in your MacBook Pro, and you will need to control the audio through your speakers or monitor. There should be an audio control on the speakers, or you may have been provided a remote to use with the monitor/speakers.

  • No problem. As a side note, I discovered that when I upgraded to Yosemite from Mavericks, OS X suddenly started using my external monitors as the default audio output. This was despite it being configured to use the internal speakers prior to the upgrade. – Lingnik Oct 24 '14 at 15:59
  • @Lingnik Likewise, Yosemite now defaults to the external always for me. – jrg Oct 28 '14 at 17:35
  • I have a different monitor at work (DisplayPort) and at home (DVI) and whenever I show up at work I always have to switch the audio back to internal speakers cause it tries to use the Monitor. That's annoying. – Ben Roberts Oct 29 '14 at 16:09
  • @Lingnik Updated to ⌥ Option-key, it's not control. – Rob Nov 16 '14 at 11:00
7

If you are still unable to solve the problem, try killing all apps that output audio and running them again. In a terminal, do this:

sudo killall coreaudiod

Now run your audio program, and you should be able to adjust the volume level again.

  • I was switching between different external outputs and completely lost the sound at some point. One of applications must have not released the resource properly. This command solved my problem. – plexoos Jun 29 '16 at 20:40
3

Solution is, plug in a headphone/earpiece, then unplug. Worked for me.

  • boom - @Shamim! – J.Wells Nov 16 '14 at 22:20
  • This workaround worked for me too when this happened to my macbook despite not having any external speakers – Michael Lang Jan 4 '15 at 18:28
2

Sometimes the sound won't work in Yosemite even though you've made the right output sound settings.

If that's the case, try resetting the PRAM by starting (or restarting) your mac WHILE pressing alt+cmd+p+r simultaneously. Keep holding the keys until you hear a second start up sound, then release the keys and let your mac finish its start up. When you now choose the right output device the sound should work.

I've noted that it's no longer possible to just plug-and-play some headphones that used to work just fine - sometimes you have to plug them in and then choose the headphones option in your output sound options.

2
  • Go to System Preferences
  • Go to Sound
  • On the top centre there is Output tab, navigate to there
  • Then select your output
  • Welcome to Ask Different. While your answer is technically correct, please see the accepted answer for an example of how to present the answer in a more informative manner. – tubedogg Nov 16 '14 at 8:43
-1

The solution is not to install hot-off-the-presses new OS versions that aren't ready for showtime. I have not heeded my own advice. I encountered the same problem.

  • This is not an answer to the question. Please refrain from adding "I'm having this problem, too" comments unless you have additional details to provide to assist in answering the question. – tubedogg Nov 16 '14 at 8:44
  • Absolutely... None of these answers solved my problem. Of course I have internal speakers selected. – Bryan Dec 26 '14 at 20:31

You must log in to answer this question.

protected by Community Nov 17 '14 at 5:50

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .