2

Here is my situation: I have an MBP Retina 2013 with an SSD drive which I ran with Mavericks with no problems for about almost a year now. I recently upgraded to Yosemite which seemed to work well at first, but I found that it kept freezing up after an hour or two. This was unacceptable and I was unable to determine the cause so I decided to revert to Mavericks using my Time Machine backups, so I rebooted using cmd R. I selected Restore from Time Machine backup and followed the steps including unlocking the FileVault. It began to restore and then said it couldn't continue because of some sort of unspecified error.

So I tried to use the disk utility to erase the disk but the erase button was disabled. I did verify and repair on the Macintosh HD which did not report any errors.

Then I attempted to begin a reinstall OS X but that only sees the "Recovery HD", it doesn't see my main disk partition so I can't install.

Then I rebooted, hoping to simply boot back into Yosemite but it continues to boot to OS X Utilities no matter what I do. Now I try to do a Restore From Time Machine backup and its no longer able to find my Yosemite boot drive! I try selecting "Startup Disk" which doesn't find any startup disks. Somehow the main drive seems to be lost, I'm unable to erase it or even access it, what do I do?

Top drive partition ("Macintosh HD") does show under disk utility Partition: Name Macintosh HD, Format Mac OS Extended (journaled), Size 750.42 GB.

Edit: I've also tried booting to my DiskWarrior DVD but it just hangs on the Apple screen and never gets there! My next approach is to build a Mavericks USB bootable drive and see if I can install from there.

It seems clear that my main hard drive is locked or disabled somehow, I just don't know how to get it turned back on.

  • What does the partition information look like for that drive? (Disk Utility > select the top drive > Partition) – deceze Oct 24 '14 at 3:15
  • (Want this to be a comment) Do you have any backups or Time Machine entries to revert to? – 1'' Oct 24 '14 at 3:17
  • @deceze I've edited original post to show partition info. – Alan Moore Oct 24 '14 at 3:52
  • @user3473227 yes I have a Time Machine entry to revert to, but I have not been able to restore it to my hard drive as I described above. – Alan Moore Oct 24 '14 at 3:52
  • You can try to use a recovery usb gottabemobile.com/2014/10/20/… – StrawHara Oct 24 '14 at 4:37
8
+100
  1. Restart your Mac to Recovery Mode by pressing cmd R at startup
  2. Launch Terminal from the menubar Utilities->Terminal
  3. Enter the following command at the Terminal prompt:

    defaults write com.apple.DiskUtility DUDebugMenuEnabled 1
    
  4. Press enter
  5. Quit Terminal
  6. Start Disk Utility and enable Show every Partition in the Debug menu
  7. After a few seconds all partitions should be visible
  8. Activate the partition Macintosh HD if it's present and greyed out.
  9. Erasing/formating of Macintosh HD should be possible now.

If this doesn't work quit Disk Utility and according to this site

  1. Start Terminal and enter following command at the Terminal prompt:

    diskutil cs list
    

    This will give you a list of the CoreStorage volumes on your system. Your old FileVault 2-encrypted drive should be the only one listed.

  2. Copy the Logical Volume Group (LVG) alphanumeric UUID of your CoreStorage volume. The LVG should be the first UUID listed and it’s the one you want to delete.

  3. Next, run the following command:

    diskutil cs delete lvgUUID #replace lvgUUID here by the UUID you found above
    

    This will delete your CoreStorage volume and reformat it as an unencrypted HFS+ volume.

If it's still impossible to erase Macintosh HD or if it's not present consider the Internet Recovery Mode or a USB Recovery drive and format the whole internal drive.

  1. Restart to Internet Recovery Mode by pressing alt cmd R at startup.
    The prerequisites are the latest firmware update installed, either ethernet or WLAN (WPA/WPA2) and a router with DHCP activated.
    On a 50 Mbps-line it takes about 4 min (presenting a small animated globe) to boot to the recovery netboot image which is loaded from an Apple/Akamai server.
  2. In the opening window choose Disk Utility and format/partition the internal drive. Choose Mac OS Extended (Journaled) and GUID partition table (available with the Options... button). Quit Disk Utility.
  3. Plug in your Time Machine backup drive.
  4. Start Time Machine and recover your old system
  • Thanks so much, what an awesome answer! The first approach worked like a charm. It is restoring from my Time Machine even as I'm typing. – Alan Moore Oct 24 '14 at 23:03
  • 1
    I created an account just to say "Thank you man"! I've been searching for this solution for two days in a row! – vooD Mar 12 '15 at 5:26
  • @vooD ;-) You are welcome! – klanomath Mar 12 '15 at 6:41

You must log in to answer this question.

protected by Community Feb 11 '15 at 21:03

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .