0

My macbook pro (mid-2010 running 10.9.5) has been crashing a lot lately. I haven't made any changes to it (either hardware or software) or installed anything new but it seems to be something to do with a kernel process "mdworker".

After each crash and when I log in again spotlight starts indexing immediately. This further causes temperatures to rise about 90 degrees and usually the macbook pro will then go into a cycle of crashes.

It seems to be all due to spotlight indexing.

Why?

  • 1
    Are you sure it's indexing? or is it just that 'mdworker' taking a very high % in Activity Monitor? If it's the latter, I may have a solution. – zerohedge Oct 23 '14 at 17:47
  • Does it finish indexing before it crashes? – woff Oct 23 '14 at 17:48
  • To fix the root cause we need you console report at the time stamp of the crash and the actual crash report. mdworker is not causing the crash but doing its job. – Ruskes Oct 23 '14 at 17:48
  • @zerohedge it's indexing because I see a message when I click on the spotlight search icon that says "Estimating Index Size ... " and a progress bar. Then it goes on and starts indexing. – motionpotion Oct 23 '14 at 17:50
  • @mehmenmike It does seem to finish but the temps go up to almost 100 degrees while it is indexing. I've tried repairing permissions and repairing disks. The crash seems to be random at first be are compounded by spotlight indexing at restart which causes the crash cycle. – motionpotion Oct 23 '14 at 17:52
2

While reading up on this, I found two prevalent suggestions. One from this Ask Different thread:

Try to erase the Spotlight index by either running sudo mdutil -Ea or by temporarily adding your startup disk to the privacy tab in the Spotlight preference pane.

If that doesn't work, try to run:

sudo lsof|grep mdworker

or

sudo mdutil -Ea;opensnoop -n mdworker

to see if the indexing hangs on some specific files.

And the second, which I actually feel is more relevant to your case since your machine does finish indexing, suggested this:

After trying everything under the sun, here's what fixed it for me

Booted in Safe Mode and ran the free utility OnyX.

Cleaned system caches, repaired/restored permissions.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .