1

My Mac is running OS X Mavericks (1.9.5) and iTunes 11.1.

After I upgraded my iPhone to iOS 7 to iOS 8, I get a message saying that I need at least iTunes 11.2 to connect to this iPhone. However, when I click on the "upgrade" button, App Store only gives me the option of upgrading to Yosemite. I can't find a way to just install iTunes 11.2 or whatever version without upgrading to Yosemite.

Is there any place where I can download older iTunes versions?

thanks!

  • FYI. when I open Apple Store it shows iTunes 12.0.1 as available update, so the 11.2 has been replaced with newer version. – Ruskes Oct 23 '14 at 17:28
  • apple.com/fr/itunes/download – StrawHara Oct 23 '14 at 17:29
1

Download the latest version from the Apple Support Downloads here

-1

If you click on the more button, you can pick and choose which thing to upgrade.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .