5

I just updated to Yosemite, and now I cant access newly added files through the dropdown menu the Dropbox icon in the toolbar provides.

Previously it was possible to reveal a newly added file in finder if a file on the dropdown list was pressed(See picture) But now nothing happens!

Am I the only that has this problem?

The problem..

10 Answers 10

3

Here is how I solved it:

  1. Restart finder via terminal command or just reboot (copy/paste into Terminal: killall Finder && open /System/Library/CoreServices/Finder.app)

  2. Finder > Go tab > Go To Folder

  3. Drag DropBox to the left favorite column

Works!

1

I got it working. I restarted my Mac and now its working again. Weird..

1

Post Yosemite upgrade, Dropbox contextual menu items and sync status icons in Finder were gone. I downloaded and installed latest 2.10.41 build and that fixed it. Until I rebooted. Then, gone again!

0

Yosemite did something to my finder involving Dropbox. After I downloaded the new os, finder wouldn't work at all. It wasn't responding and nothing happeneded when I relaunched it. The only things that I could click on we're the on the top bar and bottom bar. So I starting closing programs until finder worked again. The culprit was Dropbox. As soon as I closed it finder started working again.

  • Welcome to Ask Different! Whilst this may be useful information, this doesn't directly answer the original question of Dropbox not revealing the location of the Dropbox folder in Finder. – grg Oct 29 '14 at 16:37
0

Make sure you've got the latest version of Dropbox. It should look like this (note the positions of the buttons is now top-left rather than top-right):

                              

  • The screenshot you posted is for an older version of Dropbox. 3.2.9 looks exactly as in the question (with the icons on the right) – Matteo Mar 31 '15 at 10:09
0

Right now Dropbox's changelog is full of entries like "More fixes for Finder on Mac OSX 10.10". I didn't notice your issues, but Dropbox kept hanging since the Yosemite upgrade.

I just updated to the latest version from Dropbox website, which got me release 2.10.41, and now everything you mention works fine (for now). But from the changelog link, you can download later stable releases which might work better.

Let me speculate on the reason: while before Yosemite Dropbox used a huge hack to extend Finder, now Apple introduced clean support for Finder Extensions, so the Dropbox integration with Finder was probably rewritten. In theory, this should make things more stable; apparently, though, the new code is not good enough yet.

0

I had the same problem. It was solved when I updated to Dropbox version 2.10.46 and relaunched Finder. You can restart finder with the following Terminal command: killall Finder && open /System/Library/CoreServices/Finder.app

0

Make sure that "Enable Finder integration" is checked in Dropbox preferences

0
  1. Open Finder.

  2. Click the "Go" tab.

  3. Click "Enclosing Folder".

  4. Navigate through the folders until you find your username, then open that folder.

  5. Scroll down till you see the Dropbox that you wish to lock in the Favourites bar.

  6. Simply drag and drop this Icon/Folder in the Favourites bar.

-2

I had the same problem too. It says it is updated but the files that I uploaded at Finder do not appear in dropbox.com. So i went to pause the sync button and sync them back again. And now it works!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .