9

Yosemite install (from Mavericks) has automatically changed the names of my network computers as shown in the Finder sidebar. For example, my name IMac now displays as my name iMac(2). My two additional Mac Airs are displaying the same problem.

I have tried changing the computer names in System Preferences (sharing/computer name/edit) to no effect with or without rebooting.

How can I return to the original computer names?

  • A clean install would do that, an update shouldn't. Which was it? – Tetsujin Oct 22 '14 at 18:16
  • A clean install shouldn't do that either, but I'm having the same problem on both a clean install and an update (as soon as I updated to GM3, which is funny…) – 0942v8653 Oct 22 '14 at 20:01
  • This was not a clean install. I installed over Mavericks. – catbrown Oct 23 '14 at 19:35
6

UPDATE 3: Updating to 10.10.4 fixes this problem. In this point release discoveryd is replaced by the previously ousted mDNSResponder.

The originally supplied workaround follows...

There is a bug between Yosemite (the daemon discoveryd) and sleep servers. These servers reside in Apple TVs and Airports and act as a proxy for a sleeping machine. For now the only fix seems to be:

  • On your computer, go to System Preferences --> Energy Saver, and untick "Wake for network access" (or maybe it is "Wake for Wi-Fi access", I think it depends on your interface type).

  • Shut down your Apple TV/s and/or Airport/s.

  • On your computer, go to System Preferences --> Sharing, and rename it as you wish.

  • Reboot your computer and check that the name change has stuck (a reboot is probably not necessary but I did so for good measure).

  • Power-up your Apple TV/s and/or Airport/s.

I no longer have the incrementing computer name problem, unless I re-enable "Wake for network access".

UPDATE 1: Updating to OS X 10.10.1 (and Apple TV to 7.0.2) didn't help.

UPDATE 2: Whilst improved, it's still broken in OS X 10.10.3. But the buggy daemon discoveryd has apparently been replaced in the 10.10.4 beta by the previously ousted mDNSResponder. So here's hoping it's fixed in the next release. Source: 9to5Mac.

  • Thanks. This worked. And it was immediate; no need to wait a day. I've reported it as a bug to Apple. – catbrown Oct 26 '14 at 15:11
  • The fix was temporary. I can still edit the computer name in prefs/sharing, but replication of the computers continues. I now have iMac, iMac(2) and iMac(3) representing a single computer. – catbrown Oct 27 '14 at 16:20
  • Sorry about that. Perhaps it was just a coincidence that it worked for me. – David Oct 28 '14 at 6:52
  • After making the above comment yesterday, I re-enabled "Wake for network access", and this morning I woke to find my computer name changed to "MacBook (2)". So there maybe something there---or it could still be a coincidence. – David Oct 28 '14 at 23:07
  • This person here claims to have a fix: http://ispire.me/fix-yosemite-rtc-alarm-wakeup-issue/ Namely: sudo /usr/libexec/PlistBuddy -c "Add :ProgramArguments: string --no-namechange" /System/Library/LaunchDaemons/com.apple.discoveryd.plist Although I'm not willing to try it. This seems to be a treatment for the symptom, not the disease. – David Oct 28 '14 at 23:20
1

Goto System Preferences/Sharing. That's where you can change your computer name.

  • 1
    As I said in my original question, that's the first thing I did and it didn't work. – catbrown Oct 23 '14 at 19:36
  • This "solution" doesn't work. – jfmercer Oct 28 '14 at 15:00
0

My workaround:

  1. Rename the Macbook to a new name (System Preferences > Sharing): e.g. Jimmy
  2. Restart Time Capsule (Applications > Utilities > AirPort Utility)
  3. Make sure there are no identical names in Capsule's connected devices (the red box in diagram below)
  4. Rename the Macbook back to original name

    enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .