1

Mostly as the title says; I have a bunch of movie files that I encoded especially using Handbrake (veryslow preset, de-noise filter, nothing else changed) and which worked fine in iTunes 11.

However, since updating to Yosemite (and iTunes 12), none of the files play properly. They play perfectly in Quicktime Player with no additionally codecs installed, and they import correctly into iTunes 12, but instead of playing smoothly I just get still frames with no audio; I can skip around but all that does is change which still frame I'm stuck on.

Does anyone know why this is the case, and what (if anything) can be done to fix it? Does iTunes 12 now use a different decoder? I know that it was always picky about which files it would let you import, but previous iTunes versions always just used Quicktime for playback, so anything that worked in Quicktime would work in iTunes.

  • Turns out the issue has something to do with certain audio formats, specifically AC3 and DTS audio in .mp4 files; Quicktime Player will play them, but iTunes won't (or rather, it tries to and fails). Re-encoding the audio into AAC fixes the problem, but it doesn't explain why one works and the other doesn't. Anyway, not sure if I should update that as the answer, or if I should close the issue instead. – Haravikk Nov 3 '14 at 19:21

You must log in to answer this question.

Browse other questions tagged .