8

A couple of days ago I updated my Macbook Pro to OS X Yosemite, the update was fine and everything seemed to be working. However since this whenever I had shut down then later logged back in or restarted my macbook I have encountered the screen pictured below.

My user profile has no picture and says [update needed] rather than my name. I can still select it, enter my password and log on. An update complete and then everything is ok. The same thing happens every time I go to log on.

Any ideas of how to solve this

Thanks

enter image description here

  • I have a similar issue except mine shows my account and my picture but it also shows another account with a blank face and says.. "update needed". I should note that I opt3d to have my disk encrypted for my own security purposes and the password I chose for the encryption is the password for that account, not sure what's going on but it's weird, tried the above solution and it didn't work for me. – user97257 Oct 23 '14 at 16:42
  • I'm having the same issue as well. Yosemite was working fine for several days until I woke up this morning and tried to I am able to enter my password. it looks like it's going to work, but my computer never logs in fully. It's stuck on my screensaver without my cursor, dock, or menu bar. When I attempt login in as the guest, a warning message saying "OS X will restart in safari safe mode... Restart?" – user97265 Oct 23 '14 at 17:28
4

Before decrypting - look in FileVault pref pane and see if there is an error about "not all accounts can decrypt this disk"

Clicking this let me supply pw's for the accounts. Once done for all bootable disks attached to the system the [update needed] entry on login window was gone for good. When I did it for my main boot disk (but befrore I booted the carbon copy cloned volume I also keep mounted) the login window showed my accounts again, but still listed the [update needed] entry, presumably because the boot shim on the unencrypted partion still didn't have credentials for all the bootable encrypted disks attached to the system...


Is FileVault (full disk encryption) enabled for your main disk? Because it was in my case, and it proved to be the cause of this error.

You can find this setting in System Preferences -> Security & Privacy -> FileVault. During the installation of OS X Yosemite, you can choose if you want to enable FileVault, and it's turned on by default. It's the first version of OS X where this is the default.

Some people think the "[Update Needed]" message has to do with a pending software update, but that's not the case. Your Mac boots from a small (always unencrypted) partition, which will show the login screen. User names and user pictures are normally stored there too, so they can be shown on the login screen. But when things have changed, and your main partition is encrypted, the bootup process can not get to this data as it has no access to your main partition, which is only unlocked after you enter your password.

To resolve this, you have to disable FileVault on your main partition, which is named "Macintosh HD" by default, and reboot afterwards. When the boot process has picked up your user name and picture, you can re-enable FileVault again.

Disabling and enabling FileVault can be done from the System Preferences pane mentioned above. You have to click the lock at the bottom of the pane and enter your password first before you can make changes. The process of decrypting and encrypting your drive can take a long time, depending on the amount of data stored on your disk. For me, it was about 1,5 hour to decrypt about 500 GB of data, and an little longer to re-encrypt it again. But you can continue working on your Mac while the decryption/encryption process goes on in the background.

So you should disable FileVault, wait for the decryption to end, and then reboot. Afterwards you can re-enable FileVault.

System Preferences FileVault pane

3

I got this message too and solved it easily:

Go to System Preferences; Users and Groups; Select the Admin User and click the padlock to make changes; enter the Admin's password; Click on the picture of the Admin; the word 'edit' should appear; Select Camera; Take a new picture of yourself and save it; Lock the padlock again; Restart the computer. You could probably take a different option instead of 'Camera' but I didn't try that.

0

I hit this issue when my Mac booted from an encrypted backup drive after a main disk failure. After clicking the "[Update Needed]" user icon and entering in the disk password, MacOS started up from that disk drive.

You must log in to answer this question.

protected by Community Oct 23 '14 at 17:32

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .