I have a qwerty keyboard, but I type in french and japanese quite often.

Up until now, I used to have kotoeri activated with Romaji writing for english and french. I used to write accentuated letters by :

option + e + letter for é, ó, etc… option + ` + letter for à è ù etc… option + i + letter for î, û, ê, etc… option + u + letter for ü, ï, ö, etc…

Under yosemite, this doesn't work anymore.

To get it back I had to activate US International – PC. But it still doesn't work properly. There is a huge bug :

when typing ' then a letter, I get á, é, etc… This is preventing me for writing properly stuffs like

l'arrosoir → lárrosoir qu'un → quún

There are a lot of stuffs like this in french. And even worse, auto-correction kicks in and transforms:

quún in quant

How can I fix this ? How can I still continue typing without learning a new keyboard layout ?

CLARIFICATION =============

I am talking about several separate bugs.

Bug on U.S. International PC keyboard layout

While using this keyboard pressing option + e then a vowel produces the right output (for instance á) the key 'actually adds an accent to a letter instead of producing the 'character (for instance quelquúninstead of quelqu'un). This is most inconvenient as the character ' alone is quite frequent in french.

Bug on U.S. keyboard layout

Hitting option + e then a vowel has no effect (same for option + u then a vowel, etc…) → Solved by deactivating and and activating again this configuration. This is the only working configuration.

Bug on kotoeri

Kotoeri configuration let the user choose which keyboard configuration to use for romaji. I have selected U.S. as usual, and I have the same issues as with the U.S. configuration below. If I select US International PC, nothing changes, I don't even get the behavior of International PC without kotoeri. This is most definitely wrong.

UPDATE ======

Selecting US Extended yields the desired behavior (the old one from US international PC). However, US Extended is not available for kotoeri.

  • @TomGewecke Right. But using US I can't do any of the accentuated letters by using either option+e or option+` or option+i or option+u. Like é,ú,í,ó,á,è,ù,ì,ò,à,â,ê,î,û,ô,ä,ë,ü,ï,ö. So I loose even more.
    – PeterG
    Oct 22, 2014 at 13:54
  • @TomGewecke Actually, I am talking about several separate broken things. I did clarify the meaning in my post. I will also create a new user and see what happens when logging in.
    – PeterG
    Oct 22, 2014 at 21:28
  • Seems to be fixed in 10.10.2. I'm using the standard U.S. keyboard.
    – epimorphic
    Feb 4, 2015 at 22:22

6 Answers 6


I'm also a kotoeri user, and it took me a while to understand what's wrong.
In fact, the former behavior (e.g. option-e, then e = é) is not available anymore
in kotoeri alphabetic (symbol A in the task bar). However, it's still available in the
US input (symbol american flag in the task bar).

What I wanted to do:
- Switch between european languages and japanese with command space;
- Get the former behaviour when in european mode.
What I did:
- Open the preferences, go to input sources;
- Remove everything except U.S and Japanese hiragana;
Then it works again. The only difference is that it used to be either
alphabet (letter A) and now it's the US input (American flag). And in
american mode, you can use all the former option + key combinations.

That's it!


  • Of course this is not going to work if you happen to have what the original poster says he has, namely "Bug in the US keyboard layout -- hitting option + e then a vowel has no effect". Nov 20, 2014 at 13:15
  • @TomGewecke Thank you for this comment. Actually, removing and adding the US keyboard again (a reboot in-between) fixed the issue. I have now been using the solution described by pascal for a month. It works well. So I mark this answer as THE answer, but it was your post that led me to this, so I made sure you don't feel left out ;)
    – PeterG
    Nov 20, 2014 at 21:15
  • @PeterG I'm curious: I only have kotoeri enabled and use the shortcuts to input accented spanish vowels and ñ. I use the Romaji mode to input non-japanese languages (no US-* at all). Your comment seem to both imply that adding and then removing the US keyboard fixed the issue, but also that you used "Pascal's solution" (which entails adding a US keyboard). So, which one is it? Nov 27, 2014 at 1:13
  • 1
    @NicolasMiari PeterG is using the fix requiring that you switch between Kotoeri and US. Are you running Yosemite and finding that you can type accented characters when the Romaji flag is at the top right of the screen? It doesn't work for me or PeterG and others. Dec 2, 2014 at 18:27
  • Thank you. No, I was just describing what I used to do on Mavericks (and expected to be able to do on Yosemite). Dec 2, 2014 at 22:11

As far as I know, Yosemite Romaji IM's failure to honor option and shift dead keys is a bug that Apple will have to fix via an OS update. It has been reported elsewhere (e.g. https://discussions.apple.com/message/26864874#26864874 ). It would be good to use Apple's feedback channel to encourage quick action on this.

The OS X 10.10.1 update does not fix this bug in Kotoeri, but the 10.10.2 update of Jan 27, 2015 DOES fix it.

The behavior described for the US International PC keyboard layout is not a bug, but intended. People who use this keyboard want the ` ~ ^ " ' keys to be dead keys for producing accented characters, and they learn to add a space when they need the stand alone version.

I have not seen any other reports of the US keyboard layout not working right in Yosemite. When the US flag is showing at the top right of the screen, you should be able to use the standard option dead keys to produce accented characters without problems. You should also be able to use the Character Picker, where you hold down the key for the base letter and a popup menu appears where you can select accented versions. If that is not the case for you, the OS is broken somewhere and may need to be reinstalled.

  • Fixed in 10.10.2 :)
    – epimorphic
    Feb 2, 2015 at 19:44

I also upgraded to Yosemite (from Mavericks) on a MacBook Pro with a US Qwerty keyboard. But I do not see any difference in behavior with the keyboard, i.e. all the combinations you indicate (option+e to get "é", ...) still work fine for me. I did not make any change during the upgrade.

My keyboard is set to plain "US" (not "US Extended" or "US International -PC").

I only type in English and French, so I don't need any additional combinations.

  • Well, incredibly, it worked. Partially. When reverting back to US, I was able to type anything I wanted the way I used to. So I also applied the modification to kotoeri (I don't need an additional US keyboad when kotoeri does it in Romaji mode), and it also worked… for a time. I switched application and I lost the ability to type accents altogether. A long time ago, I had a similar bug when moving a mac system image from a french keyboard to an US keyboard. The layout of the keyboard would change when switching app without the symbol displayed in the menu bar reflecting the change. Any idea?
    – PeterG
    Oct 26, 2014 at 19:57
  • I mean, is it possible to totally reinitialize the keyboard writing system by removing a few files ?
    – PeterG
    Oct 26, 2014 at 19:58
  • @PeterG Sometimes trashing the com.apple.HIToolbox.plist file helps with keyboard issues. But I've never actually heard of anyone losing the ability to use option keyboard shortcuts before with the US input source showing in the "flag" menu. Oct 27, 2014 at 15:48

You may want to try Ukelele (http://www.macupdate.com/app/mac/14495/ukelele). It allows you to modify keyboard layouts and save them. I just tried and it works on Yosemite.

Good luck!


A larger issue is that if OS X mistakenly thinks you have a non-Japanese keyboard than the characters like @, #, etc. will be in the wrong place, and there is no way to fix it, as Japanese is not a keyboard option in the Japanese input preferences! (It will show US, German, etc., almost everything Except the one you need!) Sometimes you can fix this by forcing the setup assistant to re-run and selecting Japanese keyboard. This does not work all the time, though.

  • Your answer has nothing at all to do with the question addressed here, which relates to a bug in two versions of Yosemite which made it impossible to create accented characters in the Romaji input method. If you want help with the problem of your machine thinking your keyboard is ANSI or ISO instead of JIS, you should post a separate question. Apr 10, 2015 at 4:26

' then space will result on a '. I think this is what you want.

  • I don't understand how you could think this procedure will let you type é with the Kotoeri Romaji keyboard layout active. If you can't explain that, please delete this answer to avoid confusing people. Dec 14, 2014 at 2:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .