8

In my company, people use shared Exchange calendars to organize their work. They see all the public calendars in Exchange after they login. Sadly, this doesn't work for me on Mac: after adding the Exchange account in System Preferences I see only my own Exchange calendar and none of the shared ones. I read here about using delegation, but I don't know what e-mail to type there, as others see these calendars just as "public". Any hints?

3

I just had this problem on mail.app and just figured it out using the instructions on this page. The instructions on the linked page are for ical. I don't have access to ical so I can't confirm that it works on ical. But it works well on calendar.app. So... I'm hoping it will work just the same for you.

Here are the steps:

  1. Login to Outlook Web Access (the web interface for your Exchange Server).
  2. Click on public folders (for me, it was all they way in the bottom left).
  3. The, navigate to the public folder of your choice (I needed a calendar).
  4. Right click on the public calendar and select copy from the context menu.
  5. Navigate back to your own mailbox (I clicked "mail" in the lower left).
  6. Right click on your own calendar and click paste (I added it to a new folder).
  7. Return to iCal and refresh (not sure how you do that in iCal).

Hope it works as well for you as it just did for me!

  • Calendar.app is just a new name for iCal. Thanks, your solution works great! Having to go to the webapp every time was really bugging me. – mik01aj Jan 27 '15 at 10:51
  • Is this a static copy or really a link to the public (dynamic) calendar? – Matthias Sep 6 '16 at 11:50
4

The above doesnt' REALLY work for people, especially not with Outlook 365. Here's the way that worked for me:

  1. With iCal open go to the menu bar at the top of the screen and select iCal, it's to the right of the Apple Symbol in the upper left corner.
  2. Select Preferences
  3. Once the Preferences window comes up select the Accounts section then select the Exchange account to bring up its information.
  4. Now select the Delegation tab.
  5. Under the list is a + sign. Click this to add a calendar.
  6. Begin typing the user's name as above and the auto-completion will begin. Once you've found the correct user's name select it to add it under the Users column.
  7. Under Accounts I can access: you will now see that user's name. You can enable or disable their calendar from displaying by checking or unchecking the boxes under the Show header.

I found these instructions from the USC website.

1

The answer from D.Woods is good if the calendar you are trying to access is not being actively updated (for example an office holiday calendar). Otherwise, if other users are actively add and removing appointments, the solution will not keep the calendars in sync. You could work around this by periodically repeating the process but this is less than ideal.

Currently, there does not appear to be a general purpose solution for this issue.

1

None of these fixes worked for me. I seemed to find a workaround though. Just FYI my situation was for accessing a shared calendar from Office 365 through iCal on a Mac, El Capitan. I'm running Windows 10 on a separate PC, Outlook 2013.

  • Sync the Mail app on the Mac with your Exchange account

  • Open Outlook on the PC, Calendars and right-click the calendar you want to share.

  • Click "Share", and "Email Calendar.."

  • Send the invite that it creates to yourself in Exchange

  • Open up that email in the Mail app on the Mac and double click the .ics file that it should contain. It should open it up in iCal.

  • Select the dropdown in the "Adding a new event" dialog and select "New Calendar" and click OK.

  • You should now see it listed under the 'On My Mac" menu.

  • This calendar is synced too so when edited somewhere else, all you need to do is close/reopen the app.

  • This is what finally worked for me. Great answer – user2233949 Nov 15 '18 at 14:00
0

The unusual answer is to add the person to your contacts app. Just the name and email are enough, this will then populate in the delegates tab in iCal and allow you to add them. It will then get the permissions from the server and the Shared Calendar will appear.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .