2

I had problems with Mavericks in getting full resolution in my monitor Dell U2713H (connected to a Mac Book Pro). I used this solution from this site to fix the problem:

I downloaded the file from http://embdev.net/attachment/167830/U2713H_U2713HM_Mac_EDID_override.zip, and after copying it to /System/Library/Displays/Overrides and rebooting, my display was showing again its awesome full resolution.

I did it again when I installed Yosemite but it does not work. Any idea to fix this problem for Yosemite?. Otherwise I will downgrade to Mavericks again. Thanks!!

  • What's the resolution the display is outputting at? – Jash Jacob Oct 22 '14 at 7:07
  • The full resolution is 2560 x 1440 a 60 Hz. When the computer boots the resolution is OK but after 3-5 seconds the resolution changes to 1080p. The only resolution options are: 1080p, 720p or 1600 x 900. – Francisco Ibañez Oct 22 '14 at 12:35
  • 1
    That's happens using the mini display port. If I use VGA (using a mini display adaptor) the maximum resolution I get is 2048 x 1152. I normally get the maximum resolution (2560 x 1440) with the Mini Display Port. – Francisco Ibañez Oct 22 '14 at 12:42
  • Not tried Yosemite yet, but Mavericks to that monitor has worked well for me with just mini-DP - > DP, no adapters, no software... makes me think it could be the cable – Tetsujin Oct 22 '14 at 17:53
  • Solved!... You need to replace the entire overrides folder and not the two files inside. My recommendation is rename the former DisplayVendorID-10ac as DisplayVendorID-10ac_old and copy the above mentioned one. It works well also with Yosemite! – Francisco Ibañez Oct 23 '14 at 6:39
1

Upgraded to Yosemite 2011 13" Macbook pro. Display port to VGA is what I used with Mavericks. As soon as I updated to Yosemite my macbook would not recognize my external display. Applecare support were stumped. Got a Display port to HDMI adapter 3rd party, and voila back in business. Yosemite does not like display port to VGA adapters. I tried apple branded VGA adapter and nothing. As soon as I switched to HDMI all resolutions appeared.

| improve this answer | |
  • My experience with VGA has never been good. Since Display Port, things have got very reliable, more-so than even DVI. VGA is a technology that is now so far out of date I doubt anyone ever checks against it for compatibility. It makes Win XP look positively modern :p – Tetsujin Feb 7 '15 at 18:06
  • On a macbook air with yosemite (10.10.1) this solution doesn't work.. Have ordered a displayport to min displayport adapter to replace the DVI to mini displayport that I'm currently using - hopefully that might fix it? – Tiff Feb 11 '15 at 13:35
1

I've had the same issue yet I found that this only happens with some VGA cords. My old VGA have a connection issue that caused the screen to have a yellow or green tint so I bought a new VGA cord and now my mac shows my display's name as just Display instead of Dell Monitor so my solution is I have to plug the old VGA in and get it to recognize the monitor, then without removing the VGA adapter, I plug in the other VGA and it shows full resolution again. It's pretty odd that this happens.

| improve this answer | |
  • I used a VGA -> Mini DisplayPort adapter, changing to DVI -> Mini DisplayPort on OS X 10.10.2 worked for me. – qff Mar 30 '15 at 8:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .