11

I use Chrome on my Macbook to send an email through Gmail. While in Gmail, on the top right corner I can see my Google (g+) profile image, but when I hit reply button to reply to an email, then instead of my Google image, it's the default icon that came with my Macbook Admin account (a hawk) being used.

Here is a screenshot of the issue:

enter image description here

This is really, really annoying and looks totally unprofessional, which makes me wondering about Apple products. I have deleted my Gmail account from the Apple's Mail app and I have also disable it from the Messages app, but still Apple's image persists.

So, how can I get rid of Apple's image appearing on Gmail? Does anybody know how those two are being connected?

NOTE: Just to note that I've used my Gmail email address to register to Apple.

  • Click on your image in the top-right corner and look at the menu that appears. What avatars show there? – tubedogg Oct 22 '14 at 4:40
  • Have the same problem. It looks like under gmail contacts my profile shows correct icon, but says the icon for google+ is my mac icon. However, when I go to google+ page the icon there is correct one. It could be a deeper google problem. – Karolis Mar 7 '15 at 23:31
4

I had this happen when I set up Messages with my Google account on a new Mac, without using Apple Mail or Contacts; suddenly Gmail was the stock image the Mac had defaulted to.

The fix was to log into Gmail via the browser, go into its settings:

Gmail settings "gear menu"

-- the gear menu, not the Google Account menu (which was still showing my usual Google profile picture), where I found the offending image in the My Picture section, and was able to change it.

enter image description here

9

Apple did not change your Gmail profile picture. What is (likely) actually happening is the following:

When you add a Gmail account to Mail.app, you can choose to sync contacts with Google. (It might even do it by default. I am not sure because it has been years since I set it up.) If you do so, all of the contacts in Contacts (Address Book) on your Mac will be sent to Google, including the contact that represents you. If you did not set up a specific contact for yourself in Mac Contacts, Apple did so and for that contact, the picture would have been the one used for your Mac user account.

When the contacts synced to Google, the one with your name, email and the hawk picture was sent along with it. Google reads your contacts and displays the icon from your contacts, NOT your Gmail/Google+ profile picture, next to the Reply/Forward box.

To test this, confirm you have a contact in your Gmail account that has your email address in it, and that it has that picture. Delete that contact and the picture next to the Reply/Forward box should return to normal. You can prevent this going forward by changing the picture for your entry in Contacts on your Mac.

  • 1
    Thanks for the info. I still insist that Apple changed my Gmail picture when I chose to Sync (I mean, it could have easily not done it, but chose to do it). As you said, "the email and the hawk picture was sent along with it". But the thing is, I use the same email for both my Apple and Gmail accounts, so nothing new was added to my Gmail account except the hawk image. I checked my Gmail contacts and my own email is not there. Also, I don't like that Syncing means that "I am going to choose a picture for you as well". Especially if that picture is the default Macbook icon. – Michael Oct 24 '14 at 1:25
  • Even if it doesn't have your email address on it, is there not a contact in your Google contacts that has your name on it? – tubedogg Oct 24 '14 at 4:36
1

You are probably syncing Google contacts to the Contacts app in OS X. If this is the case, you can edit the image by finding your contact card in the Contacts app and clicking the image to choose a new one. This change should then sync to your Google account.

If you want to turn contact syncing off for your Google account, you can do so in System Preferences > Internet Accounts.

  • Thanks for the help. I actually didn't want to change my Apple image just so my Gmail image changes as well. Makes no sense to me. I tried turning Syncing off but that had no effect. – Michael Oct 24 '14 at 1:30
1

I have the same problem and eventually managed to resolve it. Have to say that this is exceptionally annoying.

I ultimately fixed this by updating the Mac contact for myself. Because I couldn't simply upload a picture (more detail below), I did this by copying the picture to the \Library\User pictures\Fun folder, then editing the contact in the Contacts app (where my picture was now available to select under "Default").

That's the solution, now for my rant (and hopefully at least some useful background info):

Firstly, the image does not come from the gmail contact, it comes from the gmail "My picture" setting. If you go into settings in gmail the incorrect picture is shown there as well. It might well originate from the Mac contact, but in gmail it does NOT come from the contact, so updating the contact in gmail will not change it.

Secondly, switching off contact sync to solve this is really not a solution. If you have hundreds of contacts that you would like to keep in sync then it doesn't make sense to switch it off just because Apple has introduced some rogue behaviour that updates a gmail setting from one contact instead of just syncing the contacts like it was supposed to.

Thirdly, when I do go to my own contact in Gmail, the image is not the incorrect Apple one, it's my image that I want to use. So it seems that the contact sync, instead of syncing the contact image to the contact (which would make some sense) actually does not do that and instead it updates the Gmail picture setting. I'm not 100% sure it is the contact sync that's to blame though. From various google forums posts a lot of users reported similar behaviour with chat clients (esp. Pidgin) updating the gmail pic, so I suspect Jabber in my case is to blame and not the contact sync.

To make matters worse the Apple contact picture options are really limited. I.e. I cannot simply upload a photo. It has to come from iCloud, or from Camera, or from Photos. Since I don't use the default Mac photos app and do not store my photos on iCloud I cannot upload the right picture and had to resort to copying the file to the app's library folder as described above.

Not sure if this is an Apple issue with contact sync or Jabber or a Google issue (Gmail should not allow these apps to change the settings surely!), but it is very annoying.

0

I actually ended up deleting the hawk image from inside the Gmail Settings.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .