9

In the "To:" box in the Messages app on OS X, when I start typing in a contact name, I get old "iMessage" contacts which I've long since deleted. They certainly don't exist in my contacts; the only place I think they could exist is in my iMessage History somewhere on the iCloud servers. In any case, how can I delete them? Thanks.

7
  • Isn't there an i next to their name?
    – Rob
    Commented Oct 21, 2014 at 18:59
  • 1
    @Rob: Nope... afraid not. Just the text "iMessage". Some names/numbers also have a chat bubble toward the right of the dropdown, but not all (in particular the ones I want to delete).
    – Noldorin
    Commented Oct 21, 2014 at 19:02
  • Are you sure they're in no address list which has been connected to your account?
    – Rob
    Commented Oct 21, 2014 at 19:05
  • 1
    @Rob: Yep, 100% sure. It seems to be something stored/cached by iMessage, annoyingly.
    – Noldorin
    Commented Oct 21, 2014 at 19:06
  • How in the world has this not been fixed yet? I have a contact where I used to just be able to type there name but for some time now it's been autocompleting to an invalid address
    – Allison
    Commented Apr 30, 2017 at 0:56

5 Answers 5

2

The answer provided by @Noldorin works for me:

Messages on OS X doesn't allow "Recent" contacts to be deleted, but Messages on iOS does allow this. An oversight by Apple, but this is a fix nonetheless.

To clarify, I looked at recent addresses on my iPhone/iMessage when starting a new conversation. There's an "i" symbol which allows your to see recent group conversations and addresses, and also a remove button.

Once removed the erroneous address is no longer visible in OS X iMessage.

0

Just found the solution myself: Messages on OS X doesn't allow "Recent" contacts to be deleted, but Messages on iOS does allow this. An oversight by Apple, but this is a fix nonetheless.

4
  • Not really a fix. It's removed from iOS but it still shows up in OS X. Commented Feb 25, 2015 at 3:03
  • @MarqueIV: Not true at all; it is removed from both, since the data is stored in iCloud!
    – Noldorin
    Commented Feb 25, 2015 at 16:01
  • Actually, what you stated isn't true because I have two iPads, an iPhone 6 and my mac, all syncing their contacts through iCloud, and even though I successfully deleted the contact (which propagated the delete), then manually did the 'Remove from Recents' on all iDevices (where it now no longer shows up) it does still show up on the Mac. I deleted the contact weeks ago. Commented Mar 19, 2015 at 4:43
  • @MarqueIV: Looks like you have a problem with your account then, because I have three Apple devices, and it works just fine. I suggest you ring up Apple and complain.
    – Noldorin
    Commented Mar 20, 2015 at 15:58
0

You need to remove the person in iMessage on iOS device (when typing the name of the person that should not be in your contacts anymore, that person's name may still appear. press the little "i" icon on the right and choose "remove from recent"), Quit and reopen imessage on OS X, when you start typing that name it will no longer show. It syncs from the iOS device

0

i found the solution i submitted it here , but was refused

un check all the boxes in application messages general un check all the boxes in application messages general

Sorry : wrong picture ,should have uploaded a screenshot of picture containing entry rudy send a message and click delete

take an entry and send a message

take an entry and send a message

the following message will appear, if you delete the converation

the following message will appear

entry rudy will be gone

entry rudy will be gone

1
  • there might be a problem if on your iPhone the setting is keep forever the messages . may be set this to 30 days, Might also be related to the OS , this works in OS Sierra Commented Sep 3, 2018 at 10:39
0

This worked for me:

Go to settings, accounts and passwords, iCloud. Then where it says “apps using iCloud” turn off contacts.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .