8

I have three nested folders in my trash: folder1/folder2/folder3. They were on an external FAT32 drive but were deleted, along with all the files inside them, a while ago.

When I try to empty the trash on Yosemite, I get a "file in use" error. I get this even after reboots, with no programs open, and nothing which could be using it.

Navigating to /Volumes/External_name/.Trashes/501/folder1/folder2/folder3 with Terminal gives me a very weird error: I call ls and obtain:

username-Mac:folder3 username$ ls
Filename_with_ö.mp3
username-Mac:folder3 username$ ls -l
ls: Filename_with_ö.mp3: No such file or directory

I strongly suspect it's something to do with the interaction between OS X, FAT32, and that ö, but I have no idea how to delete a file which doesn't seem to exist... any ideas?

Solutions tried

Finder > "Secure Empty Trash" still gives me the "file in use" error. "Disk Utility" > "Repair disk" doesn't fix it either. Also tried:

username-Mac:folder3 username$ sudo rm -r F*
rm: Filename_with_ö.mp3: No such file or directory

and

username-Mac:/ username$ sudo rm -r /Volumes/external_name/.Trashes
rm: /Volumes/external_name/.Trashes/501/folder1/folder2/folder3/Filename_with_ö.mp3: No such file or directory
rm: /Volumes/external_name/.Trashes/501/folder1/folder2/folder3: Directory not empty
rm: /Volumes/external_name/.Trashes/501/folder1/folder2: Directory not empty
rm: /Volumes/external_name/.Trashes/501/folder1: Directory not empty
rm: /Volumes/external_name/.Trashes/501: Directory not empty
rm: /Volumes/external_name/.Trashes: Directory not empty

and

username-Mac:folder3 username$ mv Filename_with_ö.mp3 safe.mp3
mv: rename Filename_with_ö.mp3 to safe.mp3: No such file or directory

and

username-Mac:external_name username$ sudo mv .Trashes /external_trashes
mv: .Trashes/501/folder1/folder2/folder3/Filename_with_ö.mp3: No such file or directory
mv: /bin/cp: terminated with 1 (non-zero) status

Still no success.

  • Have you tried renaming the ö file? – AllInOne Oct 22 '14 at 15:30
  • @AllInOne I have now - see update. – DoktorDemento Oct 22 '14 at 22:17
  • Do you get a different result if you get the path to the file by dropping it into Terminal? – AllInOne Oct 23 '14 at 12:42
  • Just had something similar: it looks like MacOS struggles the details of files on FAT media if the filename has non-ASCII characters. The only workaround seems to rename the files on another system. :-( – Charlie Clark May 9 '16 at 16:59
2

I have two suggestions. My first is to try creating a folder called .Trashes elsewhere and moving it such that it would overwrite the original folder; it's possible that this would leapfrog the problem (I used a similar method to fix a problem I was having a few months ago).

Alternatively, if the external drive is FAT32, have you tried booting a Linux distro from a USB drive and using that? Alternatively you could plug the external drive into a Windows machine (Boot Camp/VirtualBox?) and see whether that can delete the offending folder.

1

Have you tried rm as root:

sudo rm -r Filename_with*

That command will ask for your administrator password.

  • 1
    It fails silently - ls still returns the filename. – DoktorDemento Oct 21 '14 at 13:34
  • @DoktorDemento try without the -f option to get error messages back – nohillside Oct 21 '14 at 13:38
  • @patrix: I get rm: Filename_with_ö.mp3: No such file or directory... – DoktorDemento Oct 21 '14 at 13:52
1

I had this issue and the only solution that worked for me was to format the external HDD the files were originally on. This emptied the trash along with the bathwater.

1

The external volumen has corrupted entries, repairing the Volume usually fixes the issue but the Disk Utility GUI may also fail. Try from the command line:

Close all the applications using the Volume, unmount it, mount it back and run:

diskutil verifyVolume /Volumes/external_name
diskutil repairvolume /Volumes/external_name

That should fix the issue.

  • 1
    Thanks. This saved my butt after a couple of months. – Farzad YZ Sep 2 at 18:48
0

I would try deleting the entire .Trashes folder on the external drive:

e.g. sudo rm -r /Volumes/externaldrive/.Trashes

OS X will rebuild the .Trashes after the fact.

—Edit— Just a thought: have you tried replacing the umlauted characters with a file rename? Say sudo mv /Volumes/externaldrive/.Trashes/501/folder1/folder2/folder3/Filename_with_ö.mp3 /Volumes/externaldrive/.Trashes/501/folder1/folder2/folder3/Filename_without_uml‌​aut.mp3

Failing that I’d try to mv the whole .Trashes to your Mac’s HFS+ hard drive.

  • 1
    Trying to delete the whole .Trashes just returns File not found followed by four successive Directory not emptys - I've updated the question. – DoktorDemento Oct 21 '14 at 13:55
  • Renaming gets No such file or directory, moving the whole folder gets the same. See the updated question. Thanks for the suggestions... – DoktorDemento Oct 22 '14 at 22:11
-1

Try "trash it", the program claims to remove sticky items from trash http://www.nonamescriptware.com/downloads/

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .